none
Error: "Load report failed" con crystalreports en aplicación de windows form C# RRS feed

  • Pregunta

  • Saludos amigos!

    Tengo el siguiente inconveniente, estoy trabajando sobre VS 2019 / C# / Winforms / SQL Server / Crystal Reports V13.0.4, en mi maquina de desarrollo ejecuto la aplicación de escritorio y me genera el reporte en crystal reports mi PC es Win 10 x64, la aplicación la construí para x86 esta definido en Project / Matico properties... / Build / Platfomrs target = x86

    En la PC cliente el sistema es Win 7 x86 y me envía el siguiente error al intentar generar el reporte:

    No tengo 2 versiones del runtime de crystalreports instalado.

    En mi PC trabajo en la ruta F:\Proyectos\Matico\ y en la PC cliente tambien lo ubique en F:\Proyectos\Matico, no se como corregir para que el reporte se funcional en el equipo cliente.

    El reporte lleva por nombre reporte1.rpt dentro del directorio F:\Proyectos\Matico\Constancias\ en ambos equipos esta ya en la misma ruta.

    En un intento más de soluciona realice esto en el Load del formulario que carga el reporte:

                Constancia reporte = new Constancia();
                reporte.Load(Application.StartupPath + @"\Proyectos\Matico\Constancias\reporte1.rpt");
    No me funciono....

    Muchas gracias por la ayuda.



    • Editado Marco Bueno lunes, 7 de septiembre de 2020 18:39 Actualizar con codigo...
    lunes, 7 de septiembre de 2020 17:42

Respuestas

  • Saludos muchas gracias Gabriel Castro R.

    Solucione el problema instalado SP 1 de Win 7 Pro y runtime de VC++ y el reporte fue generado correctamente.

    Hasta luego.

    • Marcado como respuesta Marco Bueno miércoles, 9 de septiembre de 2020 16:54
    miércoles, 9 de septiembre de 2020 16:54

Todas las respuestas

  • Hola Marco Bueno,

    Este error puede ser causado por una variedad muy grande de razones. Aquí te dejo una guía bastante detallada sobre como encontrar cual es la razón en tu caso especifico y como solucionar el problema. Espero que te sea de ayuda.  Por favor no olvides marcar una respuesta si resolviste tu consulta. Quedo pendiente de cualquier actualización. Gracias por levantar tu consulta en los foros de msdn.

     

    Saludos cordiales

    Gabriel Castro

     ____________________________ 

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 


    lunes, 7 de septiembre de 2020 20:26
    Moderador
  • Saludos muchas gracias Gabriel Castro R.

    Solucione el problema instalado SP 1 de Win 7 Pro y runtime de VC++ y el reporte fue generado correctamente.

    Hasta luego.

    • Marcado como respuesta Marco Bueno miércoles, 9 de septiembre de 2020 16:54
    miércoles, 9 de septiembre de 2020 16:54