none
Problemas con .mdf en un proyecto MVC Visual 2013 RRS feed

  • Pregunta

  • Hola buenas noches a todos,

    me surge un problema estoy realizando un tutorial de un libro de MVC 5, todo iba correctamente, pero ahora surge un problema se inserta una nueva conexión aparte de la de defaultconection pero se supone que se tiene que visualizar un archivo .mdf en la carpeta app_data y no me la crea, ya trate instalando la versión LocalDb de sql y ni eso me a servido, si me pudieran ayudar les agradecería mucho por favor

    Saludos y gracias 

    martes, 28 de octubre de 2014 0:52

Todas las respuestas

  • Copie la conexión Por Default

    cambie el nombre a la conexión y modifique el nombre de la BD a usar 

    Haga uso de esa nueva conexión en su app


    G. Poliovei

    martes, 28 de octubre de 2014 1:57
  • Disculpa no lo pude solucionar mi cadena por defecto es esta:

    <add name="DefaultConnection" connectionString="Data Source=(LocalDb)\v11.0;AttachDbFilename=|DataDirectory|\aspnet-MvcPruebaClase-20141015080009.mdf;Initial Catalog=aspnet-MvcPruebaClase-20141015080009;Integrated Security=True" providerName="System.Data.SqlClient" />


    Pero no me creo nada en la carpeta app_data

    La que cree es esta,

     <add name="AutoDBContext" connectionString="Data Source=(LocalDB)\v11.0;AttachDbFileName=|DataDirectory|\Auto.mdf;Integrated Security=True" providerName="System.Data.SqlClient" />

    martes, 28 de octubre de 2014 4:25
  • hola

    el ejemplo de casualidad utiliza entity framework ?

    cuando no lo crea la aplicacion falla con algun mensaje de error ?

    tienes definida la carpeta App_Data ?

    intenta definir en el segundo connection string el "Initial Catalog", ponel un nombre a la db y valida sino se crea dentro del servicio de sql server ?

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    martes, 28 de octubre de 2014 10:38
  • Hola Leandro, efectivamente se soluciono moviendole varias cosas, hasta el momento no he logrado establecer cual fue, una de ellas fue leer un poco en blogs y la solución fue eliminar las conexiones de la capeta \AppData\Local\Temp, ahí existia una archivo donde se ejecutaba la conexión y yo considero que eliminar esas lineas de código con un notepad++ ayudo porque después apareció , y anterior fue instalar Sql LocalDB Y actualizar el Framework con el Nut

    Saludos y gracias 

    martes, 28 de octubre de 2014 23:23