none
Problemas al logearme al servidor RRS feed

  • Pregunta

  • Buenas,

      Tengo un SQL server 2016 SP1.  El problema que tengo es que al intentarme conectar desde algunos equipos (no todos), me sale un error (adjunto imagen). El asunto es que le pego un profile al server pero no veo la conexión llegando al server, algo lo esta bloqueando.

    Alguna idea?


    Jose Miguel Salas C

    lunes, 11 de septiembre de 2017 22:26

Respuestas

Todas las respuestas

  • Buenas compañero, 

    Como supongo que todos los equipos (los que funcionan y los que no) están en la misma red, probablemente lo que este cortando la comunicación sea el firewall (del cliente probablemente,  aunque no descartes que el firewall sea selectivo a la hora de rechazar conexiones). También está la posibilidad de que haya sea el propio sql server el que tenga configuradas Ips válidas. 

    Revisa la configuración de SQL por si acaso lo primero,  porque entiendo que el usuario con el que intentas logear es el mismo no?. O usas auténticacion de Windows? 

    Una prueba rápida que puedes hacer,  en un equipo que falle,  es deshabilitar el firewall e intentarlo,  en caso de que funcione,  añade una excepción de aplicación o de puerto (según tus necesidades). 

    Si esto tampoco funciona,  revisa la configuración del firewall del servidor,  ya que puede estar configurado para aceptar las peticiones de X IP solamente. 

    En caso de que lo anterior falla,  comentanos y seguimos investigando. 

    Atte


    No olvides votar si mi comentario te ha ayudado y marcarlo como respuesta si ha sido la solución!


    martes, 12 de septiembre de 2017 7:28
  • Hola que tal. 

    Adicionalmente a lo comentó Jorge anteriormente, verificar que en los puestos que estás teniendo problemas de conectividad tengas la versión del SQL Server Native Client adecuada a SQL 2016.

    Y adicionalmente, la conexión las estas realizando mediante usuario de Active Directory? Ya que si es en este caso, deberías revisar la configuración de Kerberos.

    Saludos.


    Mariano K.

    martes, 12 de septiembre de 2017 14:35
  • Buenas,

      Efectivamente la conexión la hago por medio de usuarios de Active Directory. Como puedo revisar la configuración de Kerbero?

    Como dato adicional, el server esta funcionado bien, fue a partir de que se le aplicó una política de seguridad la cual cambiaba los siguientes parámetros.

     Aunque esta ya fue reversada, el problema persiste.


    Jose Miguel Salas C


    • Editado JoseSalas martes, 12 de septiembre de 2017 15:35
    martes, 12 de septiembre de 2017 15:34
  • Te dejo una guia para hacer troubleshooting de Kerberos :

    https://blogs.msdn.microsoft.com/sqlupdates/2014/12/05/sql-server-kerberos-and-spn-quick-reference/}

    Pudiste verificar en esos clientes que versión de Native Client se está usando?

    Saludos.


    Mariano K.

    • Propuesto como respuesta Moderador M lunes, 18 de septiembre de 2017 16:18
    • Marcado como respuesta JoseSalas martes, 19 de septiembre de 2017 19:56
    martes, 12 de septiembre de 2017 15:51