none
Mysql error 2006 RRS feed

  • Debate general

  • En una maquina virtual tengo instalado Mysql, todo funciona perfecto pero pasado un tiempo se pierde a la conexion a la base de datos y es necesario reconectar, en workbench me lanza error 2006. No entiendo por que esto solo sucede con Windows Azure anteriormente en Google Cloud no tenia ese problema. Gracias
    sábado, 16 de enero de 2016 5:28

Todas las respuestas

  • Hola Jhonriraito,

    Gracias por consultar en los foros. MySQL en Windows Azure está almacenado por ClearDB. Por favor contactales a través de su portal de Soporte.

    Saludos,

    Karen.

    _________________


    Por favor, recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema.

    Es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.


    lunes, 25 de enero de 2016 18:08
  • Hola Jhonriraito,

    Primero que nada necesitamos más información para resolver tu pregunta y saber si el problema está en tus servicio de MySQL. O si realmente el problema está en la conexión que se está cerrando del lado de la VM.

    Por el error 2006, podemos inferir que el servidor de DB puede estar cayéndose cada cierto tiempo. Mi consejo sería hacer un logging bueno de tu aplicación para tener la referencia de cuando se está cayendo, mis sospechas son:

    1.- El nivel contratado de tu DB es muy básico y no soporta la cantidad de requests o de información que quieres almacenar.

    2.- La aplicación puede generar el error al meter muchos datos o llamadas. Te recomiendo revisar los logs para verificar cuantas llamadas y cuanto tiempo se tardan. De igual manera verifica cuanto tiempo se tarda en cerrar la conexión. Puedes usar algo como esto (PHP http://php.net/manual/es/mysqli.ping.phphttp://php.net/manual/es/mysqli.ping.php) para verificar que el servicio está de vuelta.

    3.- Tu Servidor de MySQL está mal configurado (por ejemplo, podrías tener esté error: http://stackoverflow.com/questions/10474922/error-2006-hy000-mysql-server-has-gone-away)

    En fin, sin mayor entendimiento de tu aplicación, conexión de BD, servidores y lenguajes que usas. El diagnostico es muy difícil.

    Por favor, verifica mis respuestas y si alguna te sirve por favor marca mi respuesta como correcta. Adicionalmente, puedes poner más información para que te apoye a revisar el posible error.

    lunes, 25 de enero de 2016 23:00
  • Hola,

    En este caso dudo que tenga algo que ver con el servicio ya que como comentas estas usando una VM por lo que descartaría esa opción.

    Como menciono Bruno sería muy útil contar con más información sobre como estas realizando la conexión y como las estas consumiendo, también ayudaría saber si has encontrado un patrón y repro-steps para tener una idea más clara y poderte guiar de mejor manera.

    Saludos

    lunes, 1 de febrero de 2016 23:07