none
Progress Bar RRS feed

  • Pregunta

  • Hola foro,

    Tengo un windows form al cual le agregue una progress bar, resulta que quiero que se vea el progreso al hacer clic en Iniciar Secion y luego dirigir a un nuevo win form, sin embargo, como tengo el codigo solo hace lo segundo sin ver la carga.

    Espero me ayuden a que haga las dos cosas.

                           

     private void btnLogIn_Click(object sender, EventArgs e)
            {

                this.timer1.Start();

                Welcome homePage = new Welcome();
                Form.ActiveForm.Visible = false;
                AccessCodeResearch RAC = new AccessCodeResearch();
                RAC.ShowDialog(this);
            }
            private void timer1_Tick(object sender, EventArgs e)
            {
                this.proBar.Increment(12);
            }

    Saludos,

    Jonathan

    miércoles, 2 de abril de 2014 2:55

Todas las respuestas

  • Hola foro,

    Tengo un windows form al cual le agregue una progress bar, resulta que quiero que se vea el progreso al hacer clic en Iniciar Secion y luego dirigir a un nuevo win form, sin embargo, como tengo el codigo solo hace lo segundo sin ver la carga.

    Espero me ayuden a que haga las dos cosas.

                           

     private void btnLogIn_Click(object sender, EventArgs e)
            {

                this.timer1.Start();

                Welcome homePage = new Welcome();
                Form.ActiveForm.Visible = false;
                AccessCodeResearch RAC = new AccessCodeResearch();
                RAC.ShowDialog(this);
            }
            private void timer1_Tick(object sender, EventArgs e)
            {
                this.proBar.Increment(12);
            }

    Saludos,

    Jonathan

    ten en cuenta el intervalo que le asignas a timer, ya que son en milisegundos entre mayor sea el numero que le agreges mas tiempo tomara. prueba cambiandole el intervalo y nos cuentas

    juanca

    miércoles, 2 de abril de 2014 3:15
  • Hola Juanca,

    El intervalo es 50, si saco la parte de ir al nuevo form, no demaro mucho pero es visible, demorara unos 3 segundos en cargar maximo. Por ende deberia de verce. Tal vez no puedo hacer las dos cosas en el mismo boton, espero me ayuden.

    Gracias igual.

    Jonathan

    miércoles, 2 de abril de 2014 3:19