none
Al subir un servicio Web al servidor me da un error al intentar acceder a una de las bases de datos RRS feed

  • Pregunta

  • Buenas,

    He creado un Web service y lo he probado en mi maquina. Funciona correctamente.

    Al subirlo al servidor me da un error al intentar acceder a una de las bases de datos a las que tienes que acceder para hacer un insert. En realidad no se si es aquí exactamente o en el paso previo, cuando carga las Entidades que cusa para hacer el Insert.

    He vuelto a generar varias veces las dll que influyen en dicho proyecto y también he modificado varias veces el web.config, pero por ahora no he conseguido arreglar nada.

    Si necesitais q explique algo más por favor decídmelo.

     

    Muchas Gracias anticipadas.

    martes, 20 de diciembre de 2011 16:17

Respuestas

  • hola

    pero la cadena de conexion que defines para conectarte a la db, la cambias cuando subes el codigo el hosting ?

    o sea en el web.config deberias definir el connection string que define donde se cuenta y las credenciales a la db, eso debes cambiarlo

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    • Marcado como respuesta capreolus miércoles, 21 de diciembre de 2011 10:36
    martes, 20 de diciembre de 2011 19:18

Todas las respuestas

  • hola

    pero la cadena de conexion que defines para conectarte a la db, la cambias cuando subes el codigo el hosting ?

    o sea en el web.config deberias definir el connection string que define donde se cuenta y las credenciales a la db, eso debes cambiarlo

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    • Marcado como respuesta capreolus miércoles, 21 de diciembre de 2011 10:36
    martes, 20 de diciembre de 2011 19:18
  • Gracias,

    Ya lo he solucionado: era un problema de permisos.

    miércoles, 21 de diciembre de 2011 10:37