none
Problema para conectarme al SQL RRS feed

  • Pregunta

  • Buenos días,
    El problema que tengo es que el Servidor se llama nombreServidor\NombreInstancia y esa barra "\" en el medio me esta jugando una mala pasada. Estoy desarrollando en C# para PDA.
    Estuve viendo mucha info al respecto, pero ninguna pudo ser la solución. Cuando quiero ejecutar el string de coneccion al servidor que tiene ese tipo de nombre, el "\" hace como un salto y trunca todo lo que sigue.
    Se que ese operador en C# se utiliza para comentar texto y que por esta razón me invalida lo que quiero hacer...
    La única solución es desinstalar el SQL y volverlo a Instalar de forma que quede con un solo nombre?? no existe otra solución??
    Gracias y espero sus comentarios
    jueves, 23 de junio de 2011 13:40

Respuestas

  • pero alli hay unas contradicciones enormes en el connection string

    o sea entiendes alli lo que ahs puesto ?

    estas indicando que uses seguridad integrada

    Integrated Security=SSPI

    pero depsues le dices que no la uses

    Trusted_Connection=false

    y le pasas el usuario y password

    User ID=pipo;Password=pi

    lo que imagino es que de alguna forma muy rara esta tomando al seguridad de sql server

    pero estas haciando una mezcla en la conexion o usas la seguridad integrada o no la usas

     

    veo que ademas usas

    Data Source=GJI\\SQLEXPRESS

    pero este GJI, es tu pc local ? porque recuerda que la version express por defecto no permite conexiones remotas, debes habilitarlas

    Enable Remote Connection on SQL Server 2008 Express

     

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    viernes, 24 de junio de 2011 12:13

Todas las respuestas

  • hola

    recuerda que en c# la \ debes poner la como \\ para que la tome

    o sea

    string server = "nombreServidor\\NombreInstancia"

     

    o sino usar

    string server = @"nombreServidor\NombreInstancia"

    o sea el @ evita este problema

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    jueves, 23 de junio de 2011 13:48
  • Que tal Leandro, ante todo gracias por responderme; pero esas 2 alternativas que me decis, ya las probé y sigue sin funcionar. Acordate que esto lo estoy utilizando en una PDA. Creo que framework que utilizan es distinto al de las PC de escritorio, puede que esto sea el problema? La verdad es que ya no se que mas hacer...

     

    jueves, 23 de junio de 2011 17:28
  • pero te conectas directo desde la PDA al sql server ?

    porque el conenction string es lo mismo, pero debes tener caapcidad wireless para tener acceso

    sino la otra es quer te conectes por medio de de wervicio web, entcnes la PDA se coencta la servicio que estar en un IIS y este servicio si se conecta a la db

     

    quizas como en la parte de emulacion debas habilitar la conxion en tu PDA

     

    Cómo conectarse a un Servidor SQL desde el Emulador de Windows Mobile

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    jueves, 23 de junio de 2011 17:31
  • Que problema te da con las soluciones de Leandro? El Framework es diferente, pero lo del \\ funciona en CF tambien.
    Vicente Cartas Espinel - MVP XNA/DirectX

    Twitter - VicenteCartas

    Blog about C# and XNA Development

    Blog about Role Playing Games

    jueves, 23 de junio de 2011 17:58
  • Lo que me estas pasando del emulador, ya lo tengo todo eso. Hace ya tiempo que estoy programando para PDA, pero este problema aún no lo pude resolver y ahora lo necesito si o si.

    Les cuento más, agregue un origen de datos desde el visual studio, lo apunte al servidor en cuestion.. anduvo todo mas que bien y cuando veo el string de coneccion, es este:

     this._connection.ConnectionString = "Data Source=GJI\\SQLEXPRESS;Initial Catalog=Dal10;User ID=pipo;Password=pi;";

    y este es el string que armo yo:

    Data Source=GJI\\SQLEXPRESS;Initial Catalog=dal10;Integrated Security=SSPI;Trusted_Connection=false;User ID=pipo;Password=pi

    El tema es que con el de arriba, que es el que me genero intenamente el VS, me generó un dataset y cosas del VS; cualqueira de las tablas de ahi las puedo ver.

    Ahora quiero generar la coneccion con un string que estoy armando yo y me tira error!!!!!

    Que puede ser?? me esta volviendo loco esto

     

    jueves, 23 de junio de 2011 18:23
  • mmm es que desde la PDA no creo que puedas usar seguridad integrada

    o sea la parte

    Integrated Security=SSPI;Trusted_Connection=false

    no creo que te sea valido

    ademas no van los dos opciones o es Integrated Security=SSPI; o es Trusted_Connection=false, pero no los dos

    Connection strings for SQL Server 2008

     

    es por eso que el otro funciona porque usa la seguridad de sql server

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    jueves, 23 de junio de 2011 18:29
  • Probé sacando el integrated... y el trusted..  y no funciona.

    También te cuento que con el mismo string, pero apuntando a una base de datos que tiene un nombre simple, si se conecta; es decir:

    Con esto no se conecta:

    Data Source=GJI\\SQLEXPRESS;Initial Catalog=dal10;Integrated Security=SSPI;Trusted_Connection=false;User ID=pipo;Password=pi

    Con esto si se conecta:

    Data Source=Servidor2;Initial Catalog=dal10;Integrated Security=SSPI;Trusted_Connection=false;User ID=pipo;Password=pi

     

    Tendrá algo que ver el tipo de servidor, al que no se conecta es un SQLExpress y al que me conecto es un SQL standard ??

    Les paso una captura de la pantalla:

     

     

     

    viernes, 24 de junio de 2011 12:02
  • pero alli hay unas contradicciones enormes en el connection string

    o sea entiendes alli lo que ahs puesto ?

    estas indicando que uses seguridad integrada

    Integrated Security=SSPI

    pero depsues le dices que no la uses

    Trusted_Connection=false

    y le pasas el usuario y password

    User ID=pipo;Password=pi

    lo que imagino es que de alguna forma muy rara esta tomando al seguridad de sql server

    pero estas haciando una mezcla en la conexion o usas la seguridad integrada o no la usas

     

    veo que ademas usas

    Data Source=GJI\\SQLEXPRESS

    pero este GJI, es tu pc local ? porque recuerda que la version express por defecto no permite conexiones remotas, debes habilitarlas

    Enable Remote Connection on SQL Server 2008 Express

     

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    viernes, 24 de junio de 2011 12:13
  • la verdad sos un fenomeno Leandro, me estas ayudando mucho.

    Como bien me dijiste en tu ultimo mensaje, le saque todo lo que refiere a seguridad. Tambien te agrego que el acceso remoto está habilitado en todos los servidores, lo revise recien.

    Acabo de hacer 2 pruebas con distintos string de coneccion, con uno funcionó y con el otro no.

    FUNCIONO: (SQL STANDARD)

    "Data Source=SIS-10b;Initial Catalog=santo;User ID=esteban;Password=kiba;"

    NO FUNCIONO: (SQL EXPRESS)

    "Data Source=SIS-10\\SQLEXPRESS;Initial Catalog=santo;User ID=esteban;Password=kiba;"

     

    Me parece que voy a terminar desinstalando el SQL y volverlo a instalar de forma que me quede solo el nombre..



    viernes, 24 de junio de 2011 13:04