none
Habilitar FIPS 140.2 en Windows 7 (la version de cng.sys es superior a las versiones de la lista de validadas del NIST) RRS feed

  • Pregunta

  • Hola,

    Estoy trabajando en una aplicación en Windows 7 y tiene que cumplir con FIPS 140.2. Siguiendo los pasos indicados en el documento https://technet.microsoft.com/en-us/library/security/cc750357.aspx, he habilitado la opción indicada en las politicas de seguridad local del equipo, sin embargo, revisando mis versiones de los ficheros cng.sys y bcryptprimitives.dll no coinciden con las versiones indicadas que estan validadas por el NIST.

    He buscado en la web y he encontrado que estas librerias son de sistema y se actualizan con Windows Update, sin embargo no encuentro nada acerca de si se pueden cambiar y como hacerlo, lo más que he encontrado es otra persona que tiene el mismo problema y los que contestan no aportan ninguna solución al problema (https://security.stackexchange.com/questions/108282/enable-fips-140-2-in-windows-7-cng-sys-version-does-not-match-with-versions-fro). Antes de probar a cambiarlas a mano me gustaría saber si es posible y como hacerlo.

    Muchas gracias!

    martes, 31 de octubre de 2017 13:11