none
EpsonFiscalInterface.dll no puedo agregar ítem a Factura. RRS feed

  • Pregunta

  • Hola, buenos días a todos...!

    Bajé de la página el "Epson Fiscal Interface v2.06.00", instalé la dll y el ejemplo "Demo Lib Alto Nivel" (VB.NET), conecto y funciona bien, para imprimir un tique técnico, pero cuando quiero agregar ítems a un tique común se genera un mensaje "Error: 0x0204 Descripción: campos en defecto". Lo mismo me ocurre con todos los demás comprobantes, los abre bien, pero al intentar agregar ítems aparece el error y solo me queda cancelar el documento (cancela bien). Pruebo también copiando la sentencia del ejemplo en mi propio desarrollo, obteniendo el mismo error.

    retorno = ImprimirItem(ID_MODIFICADOR_AGREGAR, "Pizza fugazzeta grande", "1.000", "300.0000", ID_TASA_IVA_21_00, ID_IMPUESTO_NINGUNO, "", ID_CODIGO_INTERNO, "1234567890", "", AFIP_CODIGO_UNIDAD_MEDIDA_KILOGRAMO)

    Controlando la sintaxis con el manual, está correcta, con todos los campos en orden y del tipo correcto, pero no puedo descubrir dónde reside el error.

    ¿Ustedes pueden ayudarme...?

    Luis Eduardo Tettamanti

    Argentina


    martes, 22 de enero de 2019 12:55

Todas las respuestas

  • Hola Rodney Copperbottom

    Gracias por levantar tu consulta en los foros de MSDN. Con respecto a la misma, para poder darte una mejor atención, te solicitamos de favor que nos brindes un poco más de información acerca del problema que se te presenta.

    Gracias por usar los foros de MSDN.

    Pedro Alfaro
     ____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    martes, 22 de enero de 2019 21:46
  • Hola Luis, cómo te va?

    Pudiste resolver el problema? Estoy teniendo el mismo inconveniente y no sé la razón.

    Tengo el sistema funcionando en otras instalaciones con la impresora EPSON TM-T900. Pero en una nueva en particular me está dando el mismo error Campos en defecto al ImprimirItem.

    Agrego que, siguiendo tu ejemplo, las diferencias que tengo yo es que luego del ID_IMPUESTO_NINGUNO, agrego "0" en vez de "". Y las cantidades e importes tienen otro formato.

    retorno = ImprimirItem(200, "Pizza fugazzeta grande", "00001.0000", "0000300.0000", 5, 0, "0", 1, "1234567890", "", 7)

    Gracias!

    Saludos,

    Juan


    • Editado Juan_ARG martes, 8 de octubre de 2019 19:43
    martes, 8 de octubre de 2019 19:36
  • Hola Juan, buen día! En tu caso parece que el problema es que tenes que pasar un código interno con 50 caracteres, en tu ejemplo pasas "1234567890". Comprobá si efectivamente es eso y comentanos el resultado obtenido por favor.

    Por otro lado a mi lo de "Campos en defecto" me lo arroja cuando quiero abrir un comprobante de tipo tique factura. Si a alguien le sucedió y sabe como corregir esto les pido por favor que me ayuden. Gracias. 

    Saludos, Albano.

    jueves, 24 de octubre de 2019 14:55