none
Visual studio no me muestra la advertencia de que hay errores en mi aplicacion al compilarla RRS feed

  • Pregunta

  • Hola a todos los del foro

    TEngo un pequeño problemita, Cuando se tiene errores en el codigo de una aplicacion al momento de compilarla sale una advertencia la cual dice de los errores,  si tu le das que no importa que igual ejecute la aplicacion el la inicia de igual forma y si le dices que no detiene el proceso y te muestra los errores. Ese mensaje sale un cuadrito de esos "no volver a mostrar el mensaje" bueno yo le di alli y ahora nunca me advierte de mis errores y me tengo que dar cuenta en tiempo de ejecucion... Como puedo hacer para que me vuelva a mostrar las advertencias?

    martes, 4 de octubre de 2011 0:10

Respuestas

  • Hola,

     

    No estoy completamente seguro pues no tengo el visual a mano. Pero has provado esto:

     

    1. Herramientas

    2. Opciones

    3. En el cuadro de opciones seleccionar "Depuración" en el panel izquierdo

    4. Expandir y seleccionar "General"

    5. En la opción general, al lado derecho marcar el checkbox "Activar el asistente de excepción "

     

    Saludos



    Jason Ulloa
    Mi Blog San José, Costa Rica
    martes, 4 de octubre de 2011 0:27
  • hola

    pero no te los muestra tampoco en el Error List que por lo general esta en la parte inferior del VS ?

    apunto a esta lista imagen

    mas alla que no te detenga el codigo con el mensaje una prueba practica es compilar ante de ejecutar, o sea usar Ctrl-Shift-B para hacer un build y ver en el listaod que menciono que errores hay

    luego recien alli usar el play

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    martes, 4 de octubre de 2011 0:50

Todas las respuestas

  • Hola,

     

    No estoy completamente seguro pues no tengo el visual a mano. Pero has provado esto:

     

    1. Herramientas

    2. Opciones

    3. En el cuadro de opciones seleccionar "Depuración" en el panel izquierdo

    4. Expandir y seleccionar "General"

    5. En la opción general, al lado derecho marcar el checkbox "Activar el asistente de excepción "

     

    Saludos



    Jason Ulloa
    Mi Blog San José, Costa Rica
    martes, 4 de octubre de 2011 0:27
  • hola

    pero no te los muestra tampoco en el Error List que por lo general esta en la parte inferior del VS ?

    apunto a esta lista imagen

    mas alla que no te detenga el codigo con el mensaje una prueba practica es compilar ante de ejecutar, o sea usar Ctrl-Shift-B para hacer un build y ver en el listaod que menciono que errores hay

    luego recien alli usar el play

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    martes, 4 de octubre de 2011 0:50
  • Hola,

     

    No estoy completamente seguro pues no tengo el visual a mano. Pero has provado esto:

     

    1. Herramientas

    2. Opciones

    3. En el cuadro de opciones seleccionar "Depuración" en el panel izquierdo

    4. Expandir y seleccionar "General"

    5. En la opción general, al lado derecho marcar el checkbox "Activar el asistente de excepción "

     

    Saludos



    Jason Ulloa
    Mi Blog San José, Costa Rica
    Hola gracias.... Pero esta opcion si esta marcada ya, supongo que tendria que limpiar es alguna cookie o algo asi parecido para que se muestre d nuevo
    martes, 4 de octubre de 2011 18:36
  • hola

    pero no te los muestra tampoco en el Error List que por lo general esta en la parte inferior del VS ?

    apunto a esta lista imagen

    mas alla que no te detenga el codigo con el mensaje una prueba practica es compilar ante de ejecutar, o sea usar Ctrl-Shift-B para hacer un build y ver en el listaod que menciono que errores hay

    luego recien alli usar el play

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    Hola gracias... Si yo compilo siempre pero de igual manera abeces cuando uno supone que esta todo bien no y tambien es en ocaciones molesto
    martes, 4 de octubre de 2011 18:37
  • Hola Zr-.-

    Has podido solucionar tu problema?

    Gracias!

    Saludos.


    Eduardo Portescheller - LATAM Forum Support Engineer
    Microsoft Corporation
    jueves, 6 de octubre de 2011 17:15
    Moderador
  • Hola Zr-.-

    Has podido solucionar tu problema?

    Gracias!

    Saludos.


    Eduardo Portescheller - LATAM Forum Support Engineer
    Microsoft Corporation

    Hola como  estas,

     

    No he podido, sigue igualito!!!

    viernes, 7 de octubre de 2011 18:44
  • Trata con esto:

    Herramientas.

    Opciones

    Editor de Texto

    C#

    Avanzado

    Subrayar errores en el editor.

    Saludos

    jueves, 22 de mayo de 2014 21:25
  • debes ir a herramientas, luego hacer click en opciones, luego en el panel izquierdo hacer click en proyectos y soluciones, luego ir a generar y ejecutar, y en el panel derecho dice: al ejecutar, cuando se producen errores de compilación o implementación debemos seleccionar preguntar al iniciar

    espero te ayude

    martes, 24 de septiembre de 2019 21:18
  • Hola compañero, gracias por la ayuda, tengo el mismo error, y al tratar de usar tu solución no encuentro el ultimo paso, "subrayar en el editor de texto", si me pudieses aclarar este aspecto me solucionarías la vida!

    Muchas gracias, saludos.

    viernes, 27 de diciembre de 2019 12:10
  • Hola Tenia el mismo problema en VS 2019, lo solucione ejecutando desde el menú la opción analizar, Limpieza de código

    martin

    sábado, 3 de octubre de 2020 11:30
  • en la carpeta del proyecto, eliminar el contenido de la carpeta "bin/" y "obj/", esto con el proyecto cerrado luego abres nuevamente el proyecto y ya esta solucionado.
    • Propuesto como respuesta archivo miércoles, 27 de enero de 2021 22:31
    lunes, 11 de enero de 2021 16:12
  • Pude solucionar el problema.

    Antes de borrar el contenido del obj/ y del bin/ copie todo el proyecto con otro nombre.

    Luego de correr el proyecto sin los obj/ y los bin/, repuse la vieja versión del proyecto (con los obj/ y los bin/ y problema solucionado. Muchas gracias Necam.

    miércoles, 27 de enero de 2021 22:37
  • Hola buenas, a mi me sucedio lo mismo, resulta que en mi caso se creo una carpeta en la carpeta donde manejaba mis archivos la carpeta creada era ".vscode" y dentro contenia dos archivos .json el primero "launch.json"  y el segundo "settings.json". Desconozco la utilidad de estos archivos y por que se crearon dentro de mi carpeta pero al abrir el segundo archivo me encontre con el siguiente código:

    {
        "C_Cpp.errorSquiggles""Disabled"
    }

    Pense que al cambiar "Disabled" por "Enabled" podria solucionarse mi problema ya que el nombre de la direccion era "errorSquiggles" y lo mismo tenia que ver con el problema que había causado asique lo cambie le di a guardar cerre el VisualStudio y al volverlo a abrir mi problema estaba resuelto.

    miércoles, 7 de julio de 2021 11:14