none
Problema mapeando tablas en el EF RRS feed

  • Pregunta

  • Buenos días.

    Estoy creando un EDMX a partir de una base de datos en SQL Server, en la cual tengo una tabla de rompimiento de una relación de muchos a muchos entre dos tablas. A la hora de generar el modelo usando el EF, no se está creando la Entidad de rompimiento, y la necesito para realizar unas validaciones en el programa.


    Tengo otras tablas de rompimiento para otras relaciones muchos a muchos en otras tablas y el EF me crea las entidades sin ningún problema, pero no sé por qué únicamente esa no me la crea.

    ¿Qué he intentado?

    -Coloqué los dos ids de rompimiento como llave primaria de la tabla.

    -Eliminé las relaciones entre las tablas y la de rompimiento y las volví a hacer.

    -Eliminé el EDMX varias veces y lo volví a crear.

    -Comparé la tabla de rompimiento en cuestión con las otras que tengo, no tienen nada de diferente.

    -Las dos tablas que estoy relacionando en la tabla de rompimiento tienen sus respectivas llaves primarias.

    Agradezco de antemano su colaboración.

    Saludos,

    martes, 18 de junio de 2013 15:21

Todas las respuestas

  • A la hora de generar el modelo usando el EF, no se está creando la Entidad de rompimiento, y la necesito para realizar unas validaciones en el programa.

    pero estas seguro que es una relacion muchos a muchos ?

    por lo que comentas el esquema de la db lo generas en base al modelo

    que pasa si creas la db, con las tablas y arrastras estas a un edmx (o sea aplciarias DataBase First), puedes validar que la relacion que se creas es igual a como tu lo hiciste al aplciar Mode First

    si a partir de esto generas el sql, puedes ver creada la tabla intermedia

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    miércoles, 19 de junio de 2013 7:16