none
Problema peculiar al copiar aplicacion con base de datos access RRS feed

  • Pregunta

  • Hola, espero que puedan ayudarme, es muy extraño lo que me sucede. Paso a comentarles.
    Programe una aplicación en Visual Basic 2008 Express, la uso sin ningun problema en mi pc y en otra de un amigo.
    Hasta hace un tiempo cuando yo actualizaba datos en mi pc, le enviaba por mail los archivos *.mdb a mi amigo, el los pegaba en el directorio de la aplicacion, y cuando la ejecutaba los datos aparecian actualizados igual a los mios.
    Ahora bien, hace unos días hice lo mismo de siempre, le envie los archivos de access, pero esta vez, se ven datos viejos.
    Entonces lo probe en mi pc ejecutando la aplicacion y no habia ningun problema, pero, si por ejemplo, copiaba todo el directorio de mi pc a un pendrive, los datos vuelven a mostrarse desactualizados...

    Se entendió? A alguien le ha pasado algo similar, lo pudieron solucionar?

    Gracias!!
    jueves, 17 de septiembre de 2009 19:51

Todas las respuestas

  • hola


    has verificado que la aplicacion este utilizando el path correcto al archivo de base de datos ?

    has probado realizar un compactar y reparar de la db?
    a veces esto soluciona muchos problemas

    saludos
    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    jueves, 17 de septiembre de 2009 20:03
  • Si, eso lo verifique, de hecho en la otra pc, la de mi amigo, la unica base de datos existente es la que yo le envio, asi que no hay posibilidad que la este leyendo desde otro lado...

    Lo de compactar y reparar no lo probe, ahora lo veo!!

    Gracias por responder!!
    jueves, 17 de septiembre de 2009 20:51
  • No funciono lo de compactar y reparar, te repito, lo raro es que el mismo archivo *.mdb leido desde otra ubicacion muestra otros datos (viejos), y lo estoy abriendo desde access, eso es lo que no termino de entender, es muy raro, como puede ser que al leer un mismo archivo en dos ubicaciones diferentes del disco rigido arroje en uno informacion actualizada, y en el otro datos viejos... Que podra estar pasando?

    Saludos!!!
    jueves, 17 de septiembre de 2009 20:59
  • hola

    si abres ese archivo desde el MS Acces ve los datos actualizados o son datos viejos ?
    si copias y pisas la db nuevamente sigue el mismo problema, prueba de eliminarla y volverla a copiar

    prueba de agregar un registro al final del archivo mdb y ejecutar la aplicacion a ver si puedes ver ese registo que agregaste por fuera del sistema.


    consulta, la aplicacion es web o con winforms ?

    saludos
    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    jueves, 17 de septiembre de 2009 21:07
  • Hola

    Si lo abro con access desde la carpeta de la aplicacion veo los datos actualizados, si lo abro con access en otra carpeta cualquier veo datos viejos...
    Si copio y piso la db sigue el mismo problema, la elimino y la vuelvo a copiar y sigue el mismo problema...

    Al agregar un registro por fuera de la aplicacion el registro nuevo se ve luego de ejecutarla... que significa eso... de cualquier manera me sigue
    pareciendo extraño lo que sucede con la copia/pegado del archivo de la db...

    Es una aplicacion winforms

    Estoy bastante perdido con esto... je

    Saludos!!
    jueves, 17 de septiembre de 2009 21:49
  • hola

    si la verdad que hay que reconocer que es bastante raro, si dices que copiar la db que antes veias actualizada desde el Access, pero que luego es como que no se actualiza, la verdad si es raro

    - has probado hacer esto mismo pero en otro pc ?
    solo para descartar si tambien sucede, o es algo particular de ese equipo

    - si cierras y abres la aplicacion sigues sin poder ver las actualizaciones ?

    - prueba de apuntar la aplicacion hacia otroa ruta, o se pon el archivo que sabes tiene la info actualizada en otr carpeta y leela desde alli

    saludos
    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    viernes, 18 de septiembre de 2009 1:16
  • Hola

    A mi me pasa un caso similar, es la segunda vez que sin motivo aparente la base de datos se regresa a un estado de hace un año atras, con todas las consecuencias. Es decir se me borra todos los registros de ese año, SE BORRA LOS CAMPOS QUE CREE  EN ESE AÑO, se cambian los datos a como estubieron antes. E consultado en todo lado y no veo la manera de que pueda pasar.

    Si me pueden ayudar lo agradeceria mucho..

    Saludos.
    martes, 15 de diciembre de 2009 17:36
  • hola

     

    oye disculpa, pero tengo el mismo problema, me gustaría saber si lo pudiste solucionar....si es asi me gustaría ver si me podrías ayudar..

    te dejo mi e-mail vicmar2266@hotmail.com

    miércoles, 5 de mayo de 2010 19:36