none
click de button en gridview no funciona RRS feed

  • Pregunta

  • Hola buen dia a todos, tengo un grid con columnas estaticas, en el evento grdPrueba_RowDataBound, agrego rows hijos dinamicamente.

    Pero unicamente en un row Padre, tengo dos botones, ademas de que genero su evento Onclick:

    <asp:TemplateField HeaderText="Action">
                    <ItemTemplate>
                        <asp:Button ID="btnClear" runat="server" Text="Clear" OnClick="btnClear" style=" background-color: #CB2431; color: #FFF;" />
                    </ItemTemplate>
                </asp:TemplateField>

    Aqui mi duda y problema, es que deseo volver a cargar mi grid o volverlo a llenar cuando le doy click al boton que esta estatico en mi grid.

    Cuando se carga por primera vez el grid se realiza bien, pero al darle click en algunos botones no se vuelve a llenar el control. tengo validado el IsPostBack, intente meterlo a un updatePanel, para que al evitar el postback se me borren los rows hijos, pero no me funciona, o que me pueden recomendar?

    lunes, 22 de abril de 2019 18:36

Respuestas

Todas las respuestas

  • Hola  

    Gracias por levantar tu consulta en los foros de MSDN. Con respecto a la misma, te comento que estaremos realizando una revisión a profundidad acerca del inconveniente que se te está presentando.

    Proporcionaremos una respuesta lo más pronto posible.

    Gracias por usar los foros de MSDN.

    Carlos Ruiz
     ____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.
    lunes, 22 de abril de 2019 20:59
  • Lo resolvi con un listView
    • Propuesto como respuesta Carlos_Ruiz_M martes, 21 de mayo de 2019 17:24
    • Marcado como respuesta Pollokullos lunes, 29 de julio de 2019 21:53
    miércoles, 15 de mayo de 2019 15:34
  • Debido a que no hemos recibido alguna notificación que aún se esté presentando el problema que enuncia en vuestra consulta y que la respuesta provista provee un amplio panorama y campo de acción sobre tu duda; nos gustaría considerar la misma como resuelta debido a la respuesta apropiada proporcionada  y así proceder a calificar la misma como respuesta.

    No dudes en ampliar más sobre este tema si es que aún lo requirieras o de abrir una nueva consulta en caso de tener alguna situación o necesitarla con algún otro de los productos de Microsoft.

     

    Adicional le invito a consultar los siguientes recursos:

    Guía para formular preguntas en el foro

    Channel 9 - donde puedes encontrar una sección de:

     

     

    Gracias por usar los foros de TechNet.

    Erick Rivera

     ____

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.

     

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

     

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    viernes, 26 de julio de 2019 14:42