none
Utilizar ajax en asp.net vb2005 RRS feed

  • Pregunta

  • Hola a todos, esa es exactamente la pregunta, vi que ajax tiene muchisimas herramientas y muy buenas, las e agregado pero no me funcionan o sea, las herramientas se instalan pero no las puedo utilizar.

    por ejemplo yo baje una aplicacion que utilizaba la herramienta PasswoedStrength y no la podia hacer andar, hoy me levanto y de repente andaba, ahora hace un rato la corro de nuevo a la aplicacion y no anda, entonses me pregunto si siempre es haci de inestable siempre o tengo algo mal yo. El error que me tira es este:

    Error 1 Se está haciendo referencia indirecta al ensamblado System.Web.Extensions, versión 3.5.0.0, que contiene 'AjaxControlToolkit.PasswordStrength'. Este proyecto hace referencia a una versión anterior de System.Web.Extensions, versión 1.0.61025.0. Para utilizar 'AjaxControlToolkit.PasswordStrength', debe reemplazar la referencia a System.Web.Extensions por la versión 3.5.0.0 o una versión posterior. C:\Documents and Settings\Guillermo\Mis documentos\Visual Studio 2005\WebSites\FortalezaPassword\Default.aspx 33 

    He seguido la guia de instalacion que leandro tuttini dejo en un post similar a este pero si es solo eso no se por que no me anda ya que el agregar esas herramientas es sumamente facil. O tengo que hacer algun tipo de configuracion aparte???

    me conviene utilizar vb2008 para no tener problemas con ajax??? bno se por favor espero algun tipo de respuesta y/o orientacion. Muchas gracias

    lunes, 2 de agosto de 2010 22:13

Respuestas

  • hola

    el problema segun veo es que estas usando una version muy nueva de los controels de AJAX que no son comaptibles con VS2005, o mejor dicho con .net 2.0

    para VS2005 solo puede suar los controles de AJAX 1.0, no peudes descargar lso ultimos que solo son compatibles con VS2008 o superior

    es por eso que estas tenniedno problemas de refeerencia en als versiones y obtienes ese error que estas mostrando en el mensaje

    si vas a seguir con VS2005, descarga ajax 1.0 y usa solo esta version,sino te recomendaria que uses VS2008, y pases el proyecto a usar .net 3.5, porque con solo suar VS2008 no alcanza es la version del framework lo importante

    lo que si no sabria decirte es si este control PasswoedStrength  esta presente en la version 1.0 de ajax, por ahi es alli donde viene el problema al poner una version mas nueva no compatible con VS2005 emepzaron los conflictos con la anterior que si era compatible

    quizas te hayas quiado en un link como el siguiente

    Installing AJAX Control Toolkit For Visual Studio 2005

     

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    • Marcado como respuesta yoguille viernes, 6 de agosto de 2010 17:00
    martes, 3 de agosto de 2010 2:19