none
Error 500 en App web Asp.Net 4.0 al solicitarla desde la Wan RRS feed

  • Pregunta

  • Hola a todos!

    Paso a consultarles la situación.

    Recientemente, he desarrollado dos aplicaciones web en Asp.net VB Framework 4.5 (Visual Studio 2013) y han sido puestas en producción en un IIS 7.

    Una de ellas se la puede acceder tanto desde la LAN como desde la WAN sin problemas según el sysadmin.

    La segunda aplicación, generar un Error 500 al ser llamada desde la WAN, mientras que desde la LAN se puede acceder y usar perfectamente. Me dice el sysadmin que puede ser un problema de configuración en el web.config de mi segunda aplicación.

    Para mi no están cierto pero necesito conocer la opinión de ustedes, ya que según la lógica entiendo que si mi aplicación funciona bien en la LAN debería funcionar bien en la WAN.

    Desde ya muchas gracias de antemano por sus sugerencias.

    Saludos a todos!


    Luis

    jueves, 22 de febrero de 2018 20:37

Respuestas

  • hola

    >>La segunda aplicación, generar un Error 500 al ser llamada desde la WAN,

    ese error esta marcando un problema con el codigo

    de casualidad pones codigo en el global.asax ?

    la aplicacion expuesta a la LAN y la WAN estan en el mismo servidor? o sea no estan en un DMZ diferente? lo pregunto porque por temas de seguridad se exponen diferente los servicios

    puede que al exponer en WAN limiten el acceso y por ejemplo falle al acceder a la db, por eso el error interno que refleja el http 500

    pones algun log en el codigo, podrias poner try..catch en el codigo que tengas en el global.asax y en los eventos de la pagina de inicio

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    jueves, 22 de febrero de 2018 21:28

Todas las respuestas

  • hola

    >>La segunda aplicación, generar un Error 500 al ser llamada desde la WAN,

    ese error esta marcando un problema con el codigo

    de casualidad pones codigo en el global.asax ?

    la aplicacion expuesta a la LAN y la WAN estan en el mismo servidor? o sea no estan en un DMZ diferente? lo pregunto porque por temas de seguridad se exponen diferente los servicios

    puede que al exponer en WAN limiten el acceso y por ejemplo falle al acceder a la db, por eso el error interno que refleja el http 500

    pones algun log en el codigo, podrias poner try..catch en el codigo que tengas en el global.asax y en los eventos de la pagina de inicio

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    jueves, 22 de febrero de 2018 21:28
  • Estimado Leandro, gracias por tu pronta respuesta.

    Paso a comentarte:

    No, no tengo ningún codigo agregado por mí en Global.asax en ninguna de mis dos aplicaciones.

    La aplicaciones expuestas a la LAN y WAN, están ambas en el mismo servidor, el cual se accede desde LAN y DMZ, es decir, tiene dos interfaces de red.

    Respecto a limitar el acceso, por ejemplo a la db, lo pensé, pero ocurriría lo mismo con la primer aplicación, la cual se conecta a las mismas bases de datos que la segunda aplicación.

    Puede ser que debido a alguna regla en el FW (ISA Server ) esté generando dicho comportamiento?

    Desde ya muchas gracias!!!!


    Luis

    jueves, 22 de febrero de 2018 21:45
  • Disculpen la ignorancia...

    Por qué fue marcada como respuesta el comentario anterior, cuando el hilo de la conversación todavía no finalizó?

    Muchas gracias.

    Saludos


    Luis

    lunes, 26 de febrero de 2018 20:13