none
Como interactuar entre la v2.0 y 3.0 del framework con VS2005 RRS feed

  • Pregunta

  •  

    Hola Amigos , la verdad que me entro esta duda, despues de leer unos post anteriores ya sabemos que no basta con instalar el netframework 3.0 para trabajar con el sino tambien instalar "Visual Studio 2005 Extensions for Windows Workflow Foundation" :

    tengo instalado ambos productos pero en el about aparece que sigo trabajando con el netframework 2.0

    como puedo hacer para trabajar con la nueva version del framework ? que me esta faltando instalar en mi pc ?

    Y luego de haber instalado y configurado correctamente todo para trabajar con el 3.0, como puedo hacer para trabajar nuevamente con la version 2.0 ????

     

    Ya me hice bolas , alguien me puede ayudar a aclarar estas dudas.

     

    Gracias

     

    Percy Herrera.

    miércoles, 26 de septiembre de 2007 1:25

Todas las respuestas

  • Que tal Ariano?

     

    Realmente me ha llamado la atención lo que comentas del "about". Yo tengo instalada la versión 3, y las correspondientes extensiones, y a mí lo que me indica es un ".NET Feamework" genérico, sin indicarme una versión concreta. Supongo que debemos tener versiones distintas de Visual Studio, pero bueno... para el caso vamos a tener que seguir las mismas pautas de cara a desarrollar para uno u otro Framework.

     

    Con VS2005 nos tenemos que guiar de forma muy rudimentaria, ya que el mismo no fué pensado para trabajar con la versión 3 del Framework, sinó que como ya sabes, necesitamos "parchearlo" con las extensiones que antes comentabas. En éste contexto, digamos que nuestra aplicación de salida trabaja para la versión 2, pero que en el momento que refeernciemos alguna librería incluida en la 3, nuestra aplicación ya pasará a depender de esta versión del Framework. Así de simple y rudimentario.

     

    Con la llegado de la versión 2008 de Visual Studio la cosa ya se pone mejor, y en las opciones avanzadas de compilación del proyecto, tenemos un desplegable que nos permite escoger entre las versiones 2.0, 3.0 y 3.5 del Framework, advirtiéndonos en caso de que fuera necesario si existen incompatibilidades entre ésta selección y las librerias que hemos referenciado en nuestro proyecto.

     

    Espero haberme sabido explicar...

     

     

    Salud y suerte!

    miércoles, 26 de septiembre de 2007 4:35
  •  

    Hola Recio, gracias por la aclaracion, pense que el trabajar con la V3.0 en VS 2005 era mas ilustrativa en el sentido de que en alguna parte nos orientaria acerca de la version con las que estamos trabajando, VS2003 cuando uno creaba sus proyectos tenia la posibilidad de indicar con que version del framework trabjar si la 1.1 o 1.0. Que raro que VS 2005 no lo tenga.

     

    Gracias por la aclaracion fue de ayuda.

     

    Saludos

    miércoles, 26 de septiembre de 2007 5:29
  • Estoy de acuerdo contigo. Pero has de tener en cuenta que cuando apareció VS2003 la 1.0 ya existia, algo que no se puede decir de VS2005 y la versión 3.0. Con VS2008 todo vuelve a la normalidad...

     

     

    Recuerda marcar el hilo como contestado cuando consideres oportuno. Gracias!

    miércoles, 26 de septiembre de 2007 6:09