none
mostrar reporte en reportViewer (SQLExpress 2008 with advances services) RRS feed

  • Pregunta

  • Saludos a todos y gracias de antemano por las respuestas puse aca la pregunta por que no se si es de reporting services o de C#
    Aqui va lo que se hizo y como se tiene:

    Se ha instalado SQL Server 2008 Express with Advanced Services de la ruta (http://www.microsoft.com/es-es/download/details.aspx?id=1842) el tema de la instalación no hubo problemas asi como configurar que soporte conexiones remotas, y la apertura de puertos en el Firewall, luego se monto una base de datos y se procedio a implementar los reportes en el portal de reporting services con SQL Server Business Intelligence Development Studio incluido en SQLExpress hasta ahi todo bien

    Aqui va el problema:

    Se requiere que un reporte del portal (reporting services) se muestre en un sistema desarrollado con Visual Studio 2010 (se instalo sin sqlexpress)  con winforms y net framework 4.0 lo cual no suguiere una gran complejidad se siguio este tutorial (http://msdn.microsoft.com/es-es/library/ms251669%28v=vs.100%29.aspx) y al hacer el mismo en el paso llamado
    Configurar el control ReportViewer para el procesamiento remoto
    en el paso 2 ponemos la ruta del servidor (http://SvrData/Reports_SQLEXPRESS)
    en el paso 3 ponermos la ruta de acceso al informe (/Clientes/Clientes Morosos)
    Hasta ahi nada del otro mundo pero cuando se ejecuta este projecto el ReportViewer se queja y muestra este mensaje

    Error al conectar con el servidor de informes. Compruebe la informacion de conexion y que el servidor de informes sea compatible.
    Error de la solicitud con el codigo de estado HTTP 404: not Found

    Sin embargo entrando por el navegador web el reporte se muestra normalmente que puede estar ocurriendo supongo que es un problema de configuracion o tengo que utilizar otro control

    Una vez mas gracias por las ayudas comentarios y demas

    Americo

    jueves, 28 de febrero de 2013 0:03

Respuestas

  • Hola jose y una vez mas gracias por responder sabes ya solucione el caso y es un tema de concepto al hacer el tutorial indica

    Configurar el control ReportViewer para el procesamiento remoto
    en el paso 2 ponemos la ruta del servidor (http://SvrData/Reports_SQLEXPRESS)

    pero se debe poner la ruta URL del servicio Web no la del administrador de Informes de esta manera todo va de maravilla

    vaya con loq ue uno viene a toparce en fin asi esta solucionado

    • Marcado como respuesta AmericoES jueves, 28 de febrero de 2013 17:38
    jueves, 28 de febrero de 2013 17:37

Todas las respuestas

  • Posiblemente es un problema de permisos revisa que el usuario que estas utilizando exista en el servidor de informes lo podrás verificar en Configuración de Sitio y Configuración de Carpeta. Algo mas que agregar tu pc debe estar dentro del dominio del servidor y ese usuario con el que te autenticas en el servidor es el que debe existir en el Servidor de Informes. Suerte

    Si se solucionó tu consulta no olvides marcar la respuesta. Saludos

    jueves, 28 de febrero de 2013 14:27
  • Hola Jose
    Gracias por responder,

    Primero la Pc si esta en dominio y desde ahi se ven los reportes por el explorador correctamente por ende el tema de autenticacion esta descartado asi como la configuracion del sitio. sin embargo no puedo conseguir ver los reportes con el reportviewer en la aplicacion winforms, quiza existe alguna configuracion adicional para reportingservices que viene en SQLExpress 2008 With Advanced Services he descargado los ejemplos sobre adventureWorks y tambien siguen sin funcionar alguna idea los ejemplos los he descargado aca (http://archive.msdn.microsoft.com/Project/Download/FileDownload.aspx?ProjectName=reportviewer&DownloadId=15611) y se ha echo la configuracion correcta existe otra forma de lograr lo que deseo???

    una vez mas gracias

    jueves, 28 de febrero de 2013 17:00
  • Que visual studio tienes? Por cierto a partir del Visual Studio 2010 es necesario agregar un control ScriptManager dentro del HTML para que este se ejecute.

    Si se solucionó tu consulta no olvides marcar la respuesta. Saludos

    jueves, 28 de febrero de 2013 17:02
  • Hola jose y una vez mas gracias por responder sabes ya solucione el caso y es un tema de concepto al hacer el tutorial indica

    Configurar el control ReportViewer para el procesamiento remoto
    en el paso 2 ponemos la ruta del servidor (http://SvrData/Reports_SQLEXPRESS)

    pero se debe poner la ruta URL del servicio Web no la del administrador de Informes de esta manera todo va de maravilla

    vaya con loq ue uno viene a toparce en fin asi esta solucionado

    • Marcado como respuesta AmericoES jueves, 28 de febrero de 2013 17:38
    jueves, 28 de febrero de 2013 17:37
  • Saludos tengo el mismo problema que tenias.. pero no te entendi como lo solucionaste.. podrias explicarte mejor.. Gracias seria de gran ayuda
    viernes, 28 de junio de 2013 2:45
  • Saludos, bueno el tema con indico es de concepto aqui la solucion un poco mas detallada

    sigue este tutorial (http://msdn.microsoft.com/es-es/library/ms251669%28v=vs.100%29.aspx
    Configurar el control ReportViewer para el procesamiento remoto
    paso 1 En el panel de etiquetas inteligentes, seleccione <Informe de servidor> en la lista Elegir informe. El panel de etiquetas inteligentes se expande para mostrar los cuadros de texto Dirección URL del servidor de informes y Ruta de acceso del informe.
    paso 2 ponemos la ruta del servidor (Dirección URL del servicio web), esta le encontraras en el Administrador de configuración de Reporting Services ---> Dirección URL Del Servicio Web (es el directorio virtual)
    paso 3 ponemos la ruta de acceso al informe suponiendo que este en el directorio reportes y se llame mi reporte seria asi --->(/reportes/mi reporte)
    de esta manera todo deberá ir bien si tienes problemas no dudes en escribir

    viernes, 28 de junio de 2013 15:05