none
Error al implementar Cubo de Olap RRS feed

  • Pregunta

  •  

    Hola tengo un proyecto de Olap de Visual Studio 2005.

    Tengo varíos cubos desplegados en el servidor SQLServer 2005

    El caso es que cuando cambio algo en el proyecto de Visual Studio e intento desplegar el cubo me sale el siguiente error: Error de sistema:.

    y no me da mas detalles.

    Procesar el cubo si que me deja. No se por donde tirar.

    Gracias de antemano.

    miércoles, 20 de agosto de 2008 7:48

Respuestas

  • Hola, ya está.

    Simplemente era que en los roles tenia usuarios que ya no existian en el dominio.

    El caso es que ahora tengo otro problema.

    Tengo un campo calculado que quiero que me haga una regla de tres dependiendo de un campo boleano de la tabla de hechos.

    He convertido el campo boleano en una medida (sin agregaciones), pero no se si voy bien encaminado.

    Tengo algo así, pero [Aplic porc] que así se llama la medida del campo boleano siempre sale vacío.

     

    iif([TIEMPO].CurrentMember.Level IS [TIEMPO].[Quarter],

    iif(not [measures].[Aplica porc],[Measures].[Presupuesto],cint([TIEMPO].currentmember.Properties("Number Of Days"))*([TIEMPO].CurrentMember.parent,[Measures].[Presupuesto])/Cint([TIEMPO].currentmember.parent.Properties("Number Of Days"))),

     

     

    ¿voy bien?

    saludos y gracias de antemano.

    jueves, 21 de agosto de 2008 14:34

Todas las respuestas

  • Antes de procesar un cubo de SSAS se debe hacer deploy en el servidor, ¿estas seguro de que te deja procesar y no te despliega, o es al revés?

    miércoles, 20 de agosto de 2008 10:12
  • Hola, ya está.

    Simplemente era que en los roles tenia usuarios que ya no existian en el dominio.

    El caso es que ahora tengo otro problema.

    Tengo un campo calculado que quiero que me haga una regla de tres dependiendo de un campo boleano de la tabla de hechos.

    He convertido el campo boleano en una medida (sin agregaciones), pero no se si voy bien encaminado.

    Tengo algo así, pero [Aplic porc] que así se llama la medida del campo boleano siempre sale vacío.

     

    iif([TIEMPO].CurrentMember.Level IS [TIEMPO].[Quarter],

    iif(not [measures].[Aplica porc],[Measures].[Presupuesto],cint([TIEMPO].currentmember.Properties("Number Of Days"))*([TIEMPO].CurrentMember.parent,[Measures].[Presupuesto])/Cint([TIEMPO].currentmember.parent.Properties("Number Of Days"))),

     

     

    ¿voy bien?

    saludos y gracias de antemano.

    jueves, 21 de agosto de 2008 14:34