none
no abre animacion flash RRS feed

  • Pregunta

  • Antes que nada un saludo a todos los foristas

    Tengo un problema con una etiqueta

    Resulta que al colocar la etiqueta <deny roles="?"/> dentro de la etiqueta <authorization/>
    que esta en el archivo webconfig no me reproduce mi animación en flash que tengo en mi pagina Login.aspx
    y cuando quito la etiqueta <deny roles="?"/> en el webconfig si me lo reproduce.
    En la version de visual studio 2005 no me hacia esto pero ahora que cambie a la version 2010 da este problema.
    Ya tengo rato tratando de solucionarlo y nada.
    Agradeceré mucho su apoyo.
    Gracias

    miércoles, 16 de enero de 2013 14:39

Respuestas

  •  Ya quedo Leandro

    Di permisos para todos los usuarios en mi webconfig a mi carpeta "imagenes" que es donde tengo las imagenes y animaciones flash

    <location path="imagenes">
            <system.web>
                <authorization>
                    <allow users="*" />
                </authorization>
            </system.web>
        </location>

    Pero en la carpeta "Account" que es donde esta el archivo Login.aspx hay un archivo webconfig que por default en la version 2010 ya trae los siguiente:

     

      <system.web>
        <authorization>

            <deny users="?"/>    
        </authorization>
      </system.web>

    por lo que quite la etiqueta <deny users="?"/>

    y ya esta, ya me puede reporducir los archivos flash

    No se si esto repercuta en la seguridad de toda la aplicacion.

    Muchas gracias Leandro por tua apoyo, me despejaste muchas dudas que tenia.

    Permiteme felicitarte por tus conocimietos y por ayudarnos a todos.

    Muchas gracias

    Halt60

    • Marcado como respuesta halt60 miércoles, 16 de enero de 2013 18:19
    miércoles, 16 de enero de 2013 16:05

Todas las respuestas

  • eso es porque en la pantalla de login aun no estas autenticado, por lo que asp.net limita el acceso a los archivos y paginas que definas con el tag <deny>

    Indicar elementos públicos o privados en un mismo sitio de ASP.NET

    alli explica que deberias definir para permitir el acceso aunque no este autenticado, esto si quieres ver una imagen o archivo sin que se neceite autenticacion

    puede poner la imagen en una carpeta y darle permisos a esta en el config

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina

    miércoles, 16 de enero de 2013 14:55
  • Muchas gracias por apoyarme Leandro

    Ya definí mi directorio donde tengo mis imagenes y nada Leandro.

    Este es el codigo que tengo en el webconfig

    <?xml version="1.0"?>
    <configuration>
      <configSections>
        <section name="infragistics.web" type="System.Configuration.SingleTagSectionHandler,System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
      </configSections>
      <infragistics.web styleSetName="Default" styleSetPath="~/ig_res" />
      <connectionStrings>
        <add name="ApplicationServices" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient" />
        <add name="ConnectionString" connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\hecauarp.mdf;Integrated Security=True;User Instance=True" providerName="System.Data.SqlClient" />
      </connectionStrings>
      <system.web>
        <authorization>
            <allow roles="Masters"/>
            <allow roles="Administradores"/>
            <allow roles="Consultores"/>
            <allow roles="Invitados"/>
            <allow roles="UsuariosA"/>
            <allow roles="UsuariosB"/>
            <deny roles="?"/>
        </authorization>
        <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Drawing.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="Infragistics4.Web.v12.2, Version=12.2.20122.1007, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
            <add assembly="Infragistics4.WebUI.Documents.Reports.v12.2, Version=12.2.20122.1007, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
            <add assembly="Infragistics4.WebUI.Documents.Excel.v12.2, Version=12.2.20122.1007, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
            <add assembly="Infragistics4.WebUI.Documents.Word.v12.2, Version=12.2.20122.1007, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
            <add assembly="Infragistics4.WebUI.Documents.IO.v12.2, Version=12.2.20122.1007, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
            <add assembly="Infragistics4.WebUI.WebResizingExtender.v12.2, Version=12.2.20122.1007, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
            <add assembly="Infragistics4.WebUI.UltraWebChart.v12.2, Version=12.2.20122.1007, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
            <add assembly="Infragistics4.WebUI.Shared.v12.2, Version=12.2.20122.1007, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
          </assemblies>
        </compilation>
      
        <authentication mode="Forms">
          <forms loginUrl="~/Account/Login.aspx" timeout="2880" />
        </authentication>
      
        <membership>
          <providers>
            <clear />
            <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="ApplicationServices" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/" />
          </providers>
        </membership>
        <profile>
          <providers>
            <clear />
            <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="ApplicationServices" applicationName="/" />
          </providers>
        </profile>
        <roleManager enabled="true">
          <providers>
            <clear />
            <add connectionStringName="ApplicationServices" applicationName="/" name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" />
            <add applicationName="/" name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider" />
          </providers>
        </roleManager>
        <httpHandlers>
          <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />
          <add path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" validate="false" />
        </httpHandlers>
        <httpRuntime maxRequestLength="102400" />
      </system.web>
       
        <location path="imagenes">
            <system.web>
                <authorization>
                    <allow users="*" />
                </authorization>
            </system.web>
        </location>


        <system.webServer>
        <modules runAllManagedModulesForAllRequests="true" />
        <validation validateIntegratedModeConfiguration="false" />
        <handlers>
          <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" />
          <add name="ChartImage_axd" verb="*" preCondition="integratedMode" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" />
        </handlers>
      </system.webServer>
    </configuration>

    miércoles, 16 de enero de 2013 15:40
  •  Ya quedo Leandro

    Di permisos para todos los usuarios en mi webconfig a mi carpeta "imagenes" que es donde tengo las imagenes y animaciones flash

    <location path="imagenes">
            <system.web>
                <authorization>
                    <allow users="*" />
                </authorization>
            </system.web>
        </location>

    Pero en la carpeta "Account" que es donde esta el archivo Login.aspx hay un archivo webconfig que por default en la version 2010 ya trae los siguiente:

     

      <system.web>
        <authorization>

            <deny users="?"/>    
        </authorization>
      </system.web>

    por lo que quite la etiqueta <deny users="?"/>

    y ya esta, ya me puede reporducir los archivos flash

    No se si esto repercuta en la seguridad de toda la aplicacion.

    Muchas gracias Leandro por tua apoyo, me despejaste muchas dudas que tenia.

    Permiteme felicitarte por tus conocimietos y por ayudarnos a todos.

    Muchas gracias

    Halt60

    • Marcado como respuesta halt60 miércoles, 16 de enero de 2013 18:19
    miércoles, 16 de enero de 2013 16:05