none
CONSUMIR WEB SERVICE CON BASE DE DATOS RRS feed

  • Pregunta

  • Hoooola amig@s mi problema viene que realice un web service que hace se obtener insertar actualizar eliminar datos a una base de datos y lo cree con visual studio ahora cuando ejecuto la aplicacion me da un error :

    No se puede establecer una conexión ya que el equipo de destino denegó expresamente dicha conexión 127.0.0.1:2349

    Descripción: Excepción no controlada al ejecutar la solicitud Web actual. Revise el seguimiento de la pila para obtener más información acerca del error y dónde se originó en el código.

    Detalles de la excepción: System.Net.Sockets.SocketException: No se puede establecer una conexión ya que el equipo de destino denegó expresamente dicha conexión 127.0.0.1:2349

    No se la verdad como puedo solucionar esto ya investigado y no encuentro solucion


    SIEMPRE UN PASO MAS ADELANTE QUE LA TECNOLOGIA

    domingo, 23 de abril de 2017 3:40

Respuestas

  • Hola LUIS ANTONIO BUSTILLOS MALDONADO

    Hay distintas posibilidades por la que se puede presentar eso y no es nada de programación, muy por el contrario son de configuración, te comento algunas:

    - Primero, prueba si  te puedes conectar colocando la url del web service desde un navegador local

    - Segundo, fíjate si el firewall del servidor esta desactivado, porque ello puede causar el bloqueo de tu puerto y no te puedas conectar.

    - Tercero, fíjate si el framework está actualizado y concuerda con la versión del web service

    Saludos


    Si ayudé a resolver tu consulta, no olvides marcar como respuesta y/o votar como útil.

    domingo, 23 de abril de 2017 4:14

Todas las respuestas

  • Hola LUIS ANTONIO BUSTILLOS MALDONADO

    Hay distintas posibilidades por la que se puede presentar eso y no es nada de programación, muy por el contrario son de configuración, te comento algunas:

    - Primero, prueba si  te puedes conectar colocando la url del web service desde un navegador local

    - Segundo, fíjate si el firewall del servidor esta desactivado, porque ello puede causar el bloqueo de tu puerto y no te puedas conectar.

    - Tercero, fíjate si el framework está actualizado y concuerda con la versión del web service

    Saludos


    Si ayudé a resolver tu consulta, no olvides marcar como respuesta y/o votar como útil.

    domingo, 23 de abril de 2017 4:14
  • hola

    >>o cree con visual studio ahora cuando ejecuto la aplicacion me da un error

    o sea tienes un sitio web en el cual has agregado un asmx, no ?

    este problema lo presenta el servicio cuando ejecuta o el cliente ? porque del cliente no mencionaste nada, que tipo de aplicacion se trata?

    desde el cliente consumes el servicio por medio de una Web Reference, no? la cual crea un proxy al servicio web

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    lunes, 24 de abril de 2017 10:49