none
Ayuda con CONDICIONALES RRS feed

  • Pregunta

  • Buenas,

    Me gustaría saber porqué esta formula no funciona:

    =SI(ESBLANCO(A13);"";SI(ENCONTRAR("Texto1";A13;1)=1;"AAAA";SI(ENCONTRAR("Texto2";A13;1)=1;"BBBB";"CCCC")))

     

    Lo que quiero hacer:

    *      En caso de que A13 tenga información.

    *      Si dentro de esa información existe “texto1”, escriba AAAA

    *      Si dentro de esa información existe “texto2”, escriba BBBB

    *      Si no hay ni texto1 ni texto 2, escriba CCCC

    miércoles, 20 de julio de 2011 7:20

Todas las respuestas

  • Hay varias cosas a tener en cuenta.

    Por un lado, la función ENCONTRAR no devuelve un 1. Devuelve un entero que es la posición del texto encontrado o el error #valor en caso que no lo encuentre. Habrá que hacer uso de la función ESERROR para poder hacerlo.

    miércoles, 20 de julio de 2011 10:39
  • Mira, te respondí sin mirarlo en el Excel. En lugar de hacerlo con ESERROR, queda más sencillo con ESNUMERO:

     

    =SI(ESBLANCO(A13);"";SI(ESNUMERO(ENCONTRAR("texto1";A13;1));"AAAA";SI(ESNUMERO(ENCONTRAR("texto2";A13;1));"BBBB";"CCCC")))
    

    • Propuesto como respuesta Jesús Velasco viernes, 19 de agosto de 2011 12:00
    miércoles, 20 de julio de 2011 10:44
  • Perfecto! muchas gracias!!!
    miércoles, 20 de julio de 2011 13:37