none
Problemas con Parametros RRS feed

  • Pregunta

  • Hola Comunidad!!

    Les comento que estoy trabajando con Visual Studio 2005 y estoy generando reportes, el problema es que cuando veo la "vista previa" no me genera automáticamente el reporte ya que no se seleccionan todas las variables de un determinado parámetro.... alguna sugerencia?

    lunes, 1 de abril de 2013 20:14

Todas las respuestas

  • Hola podrías explicar un poco mejor tu problema:

    el problema es que cuando veo la "vista previa" no me genera automáticamente el reporte ya que no se seleccionan todas las variables de un determinado parámetro.... alguna sugerencia?

    Estas usando algún Reporteador? Reporting Services 2005?


    Si se solucionó tu consulta no olvides marcar la respuesta. Saludos

    lunes, 1 de abril de 2013 20:23
  • Si!

    Lo que ocurre es que ya he generado mas reportes, y cuando selecciono la pestaña "Vista Previa" me parece de manera automática el reporte, con todos los parámetros en <ALL> (Multivalor), pero el que estoy generando ahora no me aparece así, tengo que seleccionar los parámetros y luego presionar "generar informe"... lo que quiero es que apenas se llame al reporte se cargue con todos los parámetros "multivalor" y no sea necesario presionar "Generar informe"

    lunes, 1 de abril de 2013 20:29
  • Deseas colocar un valor por default a los parámetros? Si es así consulta este enlace que explica como hacerlo:

    Default Value Parameter Reporting Services


    Si se solucionó tu consulta no olvides marcar la respuesta. Saludos


    lunes, 1 de abril de 2013 20:35
  • Exacto... XP

    Lo que necesito es que por defecto aparezca de inmediato al ir a la "Vista previa" del reporte el valor de <ALL> o todos los campos seleccionados, lo que hice fue configurar los parámetros del informe, y en valores predeterminados ingrese el conjunto de datos, pero no se muestran 'seleccionados' cuando visualizo el reporte... solo se visualizan y se debe de presionar "(Seleccionar todo)" y luego "Ver informe", quiero que ese proceso sea automático....

    lunes, 1 de abril de 2013 20:39
  • Disculpa la confusión revisa este enlace:

    Parameters MultiValue Reporting Services


    Si se solucionó tu consulta no olvides marcar la respuesta. Saludos

    lunes, 1 de abril de 2013 20:45
  • Fíjate que en la última imagen, en la numero 11, cuando el tutor presiona "PREVIEW" el parámetro "Territory" se encuentra seleccionado "(Select All)", no es necesario que el usuario tenga que presionar esa casilla y luego presionar "View Report", lo que finalmente necesito es que se haga de manera automática... Revise todo el material que me enviaste y mi reporte esta igual, pero al presionar "Preview" no me parecen las casillas seleccionadas... 
    lunes, 1 de abril de 2013 20:56
  • Lo que podrías hacer es dar un valor por defecto así como se muestra en el primer enlace bueno es lo que haría para que cuando se vea el reporte me muestre algo y ya luego yo modificar los parámetros. Posiblemente alguien más pueda aportar a tu problema una mejor manera de hacerlo. Mi sugerencia es que coloques los parámetros con valores por defecto.

    Si se solucionó tu consulta no olvides marcar la respuesta. Saludos

    lunes, 1 de abril de 2013 21:07