none
No me aparece la zona de parametros en el Reportviewer RRS feed

  • Pregunta

  •  

    Buenos Dias,

     

    Yo he desarrollado diferentes aplicaciones  web utilizando Reportes de Reporting Services y siempre el ReportViewer me muestra la zona de parametros donde el usuario puede cambiar  los valores de las condiciones con que se genero el reporte.

     

    Ahora mismo me encuentro desarrollando un Software de tipo Windows Forms donde creo los reportes locales (Es decir no estoy utilizando Reporting Services) pero no me aparece la zona de parametros.

     

    Cuando  no utilizo el Reporting Services esta opcion no esta disponible?

     

    Que debo hacer?

     

    Espero una pronta respuesta.

     

    PD: La version de Visual Basic .NET es 2005 +SP1

     

    Gracias.

    martes, 2 de septiembre de 2008 12:28

Respuestas

  •  

    Despues de Investigar encontre esta pagina http://msdn.microsoft.com/es-es/library/ms251750(VS.80).aspx donde se explica que un informe procesado localmente no tiene un área de entrada de parámetros utilizada para seleccionar o escribir valores de parámetros, solo  los informes que se procesan en un servidor de informes remoto tienen esta opcion habilitada

     

    De todas maneras muchas gracias

    viernes, 5 de septiembre de 2008 13:22
  • Hola Nuria,

     

    Esconde el botón de ver informe y pon uno que vuelva a coger los parámetros de tus cajas de texto a través del setparemeters, ya que de otra forma te seguirá haciendo eso .

     

    Ya nos contarás,

     

    Un Saludo

     

    miércoles, 10 de septiembre de 2008 21:16
    Moderador

Todas las respuestas

  • Hola,

     

    Si utilizas el ReportViewer con informes con extensión *.rdlc, también estás utilizando Reporting Services (aunque si servidor). Para que te apareza la pantalla de parámetros, deberás de tener parámetros en dicho informe. Si los tienes y no te sale, mira ver en las propiedades que debe de estar la opción showparametersprompts = true.

     

    Un Saludo

     

    martes, 2 de septiembre de 2008 16:25
    Moderador
  •  

    Estoy utilizando el ReportViewer para conectarme a una base de datos de MYSQL 5, por eso estoy seguro que no estoy utlizando Reporting Services.

     

    Ya mi reporte tiene parametros y funciona correctamente, los parametros se lo mando por codigo en pruebas que he realizado y funciona correctamente. Lo que quiero es ahorarme el tiempo que me demoraria al agregar textbox o combobox a los reportes para que los usuarios modifiquen sus valores  y en vez de eso utilizen la zona de parametros de reportviewer.

     

    La propiedad ShowParametersPromts esta como viene por default, osea en True

     

    Espero la pronta respuesta de algun amigo que me pueda ayudar.

     

    Gracias 

    martes, 2 de septiembre de 2008 16:42
  •  

    Despues de Investigar encontre esta pagina http://msdn.microsoft.com/es-es/library/ms251750(VS.80).aspx donde se explica que un informe procesado localmente no tiene un área de entrada de parámetros utilizada para seleccionar o escribir valores de parámetros, solo  los informes que se procesan en un servidor de informes remoto tienen esta opcion habilitada

     

    De todas maneras muchas gracias

    viernes, 5 de septiembre de 2008 13:22
  • Hola,

     

    Estoy utilizando un contorl reportViewer en mi pagina aspx para mostrar un report.

    Este report tiene unos parametros de entrada que se los paso desde la pagina aspx con el setParametres.

    El usuario, una vez tiene el report abierto, puede canviar los parametros de entrada y volver a ver el informe. Al clickar el boton "Ver Informe" del area de parametros, vuelve a ejecutar la aspx y vuelve a poner los parametros de la página aspx, y machaca los parametros que ha puesto el usuario.

     

    ¿Cómo puedo solucionar este problema?

     

    Muchas gracias.

    miércoles, 10 de septiembre de 2008 12:19
  • Hola Nuria,

     

    Esconde el botón de ver informe y pon uno que vuelva a coger los parámetros de tus cajas de texto a través del setparemeters, ya que de otra forma te seguirá haciendo eso .

     

    Ya nos contarás,

     

    Un Saludo

     

    miércoles, 10 de septiembre de 2008 21:16
    Moderador