none
Incongruencia en la publicación/hospedaje de un WCF RRS feed

  • Pregunta

  • Buena tarde, compañeros he tenido problemas para hospedar mi servicio de wcf en VisualStudio 2012. Empecé creando un 'wcf Service Library', programo la lógica y funciona correctamente, pero luego agrego un 'wcf Service Application' para exponerlo a web y empiezan los problemas; este proyecto no me genera las configuraciones del <service.Model> con los endpoints, hice una serie de malabares para que ejecutara con las funciones q ya tenía programadas. (no se si sea correcto para un webservice).

    Si intento publicar el 'service library' solamente da opción a indicar una url tipo "localhost:00", nunca me apareció en IIS. Posteriormente con el 'service application' intenté publicarlo pero la ventana q abre no me dió opción a utilizar IIS

    Así que opté por montarlo manualmente; creo una carpeta en c:\docs\Hostwcf\ , pego el binario del proyecto,agrego un Archivo.svc y modifico el web.config.Por último en IIS creo mi aplicacion e indico la ruta física, pero al ejecutarlo desde el Servidor solo me accede a 'http://localhost:83' en navegador donde solo está pagina en blanco, paso siguiente agrego mi carpeta virtual http://localhost:83/wcfDiagnosticos/ y .. naranjas. Entonces observo mi explorador de carpetas, agrego un /CIE10.svc y.. voalá aparece el servicio con sus funciones y esquemas totalmente funcional!


    La programacion en Microsoft cada ves se torna inalcanzable



    sábado, 13 de abril de 2019 23:01