none
IIS -> Adjuntar Advertencia de Seguridad .... IIS APPPOOL\DefaultAppPool [administrador] RRS feed

  • Pregunta

  • Buen dia con todos.

    Estoy realizando un proyecto WCF con 3 capas, el servicio lo publique en el IIS 7.0, el proyecto corre perfectamente pero al momento de invocar un metodo de mi servicio me sale este mensaje:

    presiono Adjuntar y mi aplicación corre normalmente, puedo invocar los métodos de mi servicio en cualquier momento, el problema es la primera vez que ejecuto y utilizo el servicio

    es un problema de permisos o quizas configure mal el IIS??, alguien me podría ayudar a solucionar este problema??

    lunes, 23 de abril de 2012 18:35

Respuestas

  • Problema Resuelto

    el problema era por permisos del grupo de aplicaciones para ejecutarse. la configuracion por defecto es el ApplicationPoolIdentity. como los servicios son locales, simplemente le cambie a : Identidad -> LocalService. 

    Aqui les detallo el procedimiento que tienen que realizar

    1. Ingresas al IIS ( Inicio - escribir IIS ) mi version es 7.0

    2. abrir su Servidor, grupo de aplicaciones

    3. en el panel Acciones, seleccionar: Establecer valores predeterminados de grupos de aplicaciones

    4. les aparecerá un cuadro con las diferentes opciones, ir a Modelo de proceso, Identidad, a LocalService, o si prefieren, denle click en buscar, y seleccionan del combobox la opcion que les resulte mejor

    espero les ayude

    • Marcado como respuesta pepePal jueves, 26 de abril de 2012 17:42
    jueves, 26 de abril de 2012 17:42