none
Conectar contra BD Oracle 11g desde VS 2010 ultimate RRS feed

  • Pregunta

  • Hola a todos,

    Tengo que conectar contra una base de datos Oracle 11G y tengo un problema.

    He instalado en el entorno de desarrollo el ODP.NET, he agregado la referencia correspondiente al oracle.dataaccess 2.111.6.20 a mi proyecto, pero cuando intento poner al principio de mi módulo vb el Imports Oracle.DataAccess.Client no me reconoce la librería a importar. Ni siquiera al poner oracle.  me aparece nada.

    Es raro pues en la parte de agregar referencias si que me aparece lo referente a oracle, pero luego no lo puedo utilizar en el código.

    ¿que puede pasar?

    Gracias 

    martes, 27 de mayo de 2014 12:07

Todas las respuestas

  • Hola a todos,

    Soy compañero de Rafael, os aclaro un poco más. El entorno de desarrollo es un windows server 2008 R2 64 bits, el odp.net tambien de 64 bits.

    Hemos desinstaldo el odp.net y instalado de nuevo, ahora cuando hacemos el imports no nos da error, pero no hay manera de utilizarlo.

    Os cuento:

    Si hago un proyecto con un win form, agrego la referencia oracle.dataaccess 4.121.1.0  al proyecto y pongo el imports, ejecuto este simple formulario y todo va bien.

    Si por el contrario hago un formulario web, que es en lo que queremos trabajar y hago lo mismo, agregar la referencia y poner el imports, y lanzo la web, me da errores al ejecutar y si los paso por alto, me da un error diciendo que no se puede encontrar la dll que he agregado, el error que veis a continuación:

    Error de configuración

    Descripción: Error durante el procesamiento de un archivo de configuración requerido para dar servicio a esta solicitud. Revise los detalles de error específicos siguientes y modifique el archivo de configuración en consecuencia.

    Mensaje de error del analizador: No se puede cargar el archivo o ensamblado 'Oracle.DataAccess, Version=4.121.1.0, Culture=neutral, PublicKeyToken=89b483f429c47342' ni una de sus dependencias. El sistema no puede encontrar el archivo especificado.

    Error de código fuente:
    Línea 11: 		<compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
    Línea 12: 			<assemblies>
    Línea 13: 				<add assembly="Oracle.DataAccess, Version=4.121.1.0, Culture=neutral, PublicKeyToken=89B483F429C47342"/></assemblies></compilation>
    Línea 14: 		<authentication mode="Forms">
    Línea 15: 			<forms loginUrl="~/Account/Login.aspx" timeout="2880"/>

    Archivo de origen: C:\Users\adm_sanjuanalberto\Documents\Visual Studio 2010\WebSites\WebSite1\web.config    Línea: 13

    Rastro al cargar el ensamblado: La información siguiente puede ser útil para determinar porqué no se cargó el ensamblado 'Oracle.DataAccess, Version=4.121.1.0, Culture=neutral, PublicKeyToken=89b483f429c47342'.
    === 

    ¿Nos podeis ayudar?

    Gracias!!


    Empezando ;)

    martes, 27 de mayo de 2014 15:35