none
Problemas con Reporting Services. RRS feed

  • Pregunta

  • Hola.

    Tengo dos grandes problemas: 

    El primero es que cuando quiero configurar mi informe de mi servidor local no me sale el menu del reporte, por lo tanto no puedo entrar a "Seguridad" (ni a las otras opciones) y luego a "Data Sources" para configurar mi "Connection string". Ver esta imagen para que se entienda mejor:

     http://i.subirimagenes.cl/k/2013-01-07_1557.png

    El segundo es que Necesito usar los informes para varias Base de Datos porque cada BD pertenece a solo una empresa. Por eso necesito cambiar la cadena de conexión según la Base de Datos que deseo consultar. 

    Leí http://social.msdn.microsoft.com/Forums/es/repdeves/thread/470d704d-7766-471f-8d21-89d97a1df82c  pero no pude crear lo que dice "Alberto Poblacion" . Estoy trabajando con VB 2010 bajo vb.

    Espero su ayuda. Gracias

    lunes, 7 de enero de 2013 19:03

Todas las respuestas

  • Sobre la primer parte, asegurate que estas abriendo el Report manager como administrador y en Explorer, con firefox a mi no ma sale el menu

    Sobre la segunda, se puede hacer, como dice el articulo, cuando hayas concluido el reporte y publicado, lo que tienes que hacer es abrir el reporte desde el disenador y agregar una variable de Empresa, esta variable va cambiar la cadena de conexion del data source de tu reporte

    Saludos


    Gracias Ing. Salomon Bagdadi

    lunes, 7 de enero de 2013 23:32
  • Tenia que cambiar a explorer y funciono altiro.. gracias..

    al hacer lo que dice el articulo me sale :

    No se puede abrir la base de datos "Parameters!ServerName" solicitada por el inicio de sesión.

    Cree un parámetro llamado "ServerName" con los nombres de la Base de datos.. pero ni siquiera se genera el informe, me sale ese error después de abrir el link del informe.

    He intentado cambiar la cadena de conexión del archivo rdl pero no se como subirlo al servidor después.. he intentado usar una archivo de conexión compartida (para cambiar según la base de datos) pero tampoco se como subirlo y unirlo al rdl. 

    He intentado y leido mucho.. pero hasta ahora todabia no puedo.. 


    martes, 8 de enero de 2013 13:23
  • Cree una variable que se llame BaseDatos

    En el datasource del reporte puse

    =IIF(Parameters!BaseDatos.Value = "Local", "Data Source=Local;Initial Catalog=BaseDatos", "Data Source=Servidor;Initial Catalog=BaseDatos")

    Despues publique el informe y no tengo problemas

    La variable debe de ser la primera al ejecutar el informe



    Gracias Ing. Salomon Bagdadi

    martes, 8 de enero de 2013 23:23
  • ya solucione mi problema.. en este foro:

    hhh

    http://social.msdn.microsoft.com/Forums/es/repdeves/thread/470d704d-7766-471f-8d21-89d97a1df82c

    Es algo muy cercano a lo que dices, gracias igualmente..

    Saludos

    miércoles, 9 de enero de 2013 0:35