none
Error Membership Mysql RRS feed

  • Pregunta

  • Hola chicos

    He creado una app utilizando Membership pero conectado a Mysql, me ha funcionado de maravilla en mi pc sin embargo estoy intentando trasladarla a otro pc para hacerla correr y cuando lo intento me muestra el error en la imagen, ya he revisado las conexiones a la BD y estan perfectas. tampoco me permite acceder a la configuración de asp.net para gestionar la seguridad por alli.

    Este es mi webconfig 

    <?xml version="1.0" encoding="utf-8"?>
    <!--
      Para obtener más información sobre cómo configurar la aplicación de ASP.NET, visite
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <connectionStrings>
        <!--<remove name="DefaultConnection"/>
        <add name="LocalMySqlServer"
             connectionString="Datasource=localhost;Database=membershipprueba;uid=root;pwd=root;"
             providerName="MySql.Data.MySqlClient"/>-->
        <add name="DefaultConnection" connectionString="Datasource=localhost;Database=membershipprueba;uid=root;pwd=;" providerName="MySql.Data.MySqlClient" />
        <add name="facturemosConnectionString" connectionString="Datasource=localhost;Database=facturemos2;uid=root;pwd=;" providerName="MySql.Data.MySqlClient" /> 
      <remove name="LocalMySqlServer" /><add name="LocalMySqlServer" connectionString="" providerName="MySql.Data.MySqlClient" /></connectionStrings>
      <system.web>
       
        
        <roleManager enabled="true" defaultProvider="DefaultRoleProvider">
          <providers>
            <add connectionStringName="DefaultConnection" applicationName="/" name="DefaultRoleProvider" type="MySql.Web.Security.MySQLRoleProvider, MySql.Web, Version=6.9.9.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d" />
          </providers>
        </roleManager>
        <membership defaultProvider="DefaultMembershipProvider">
          <providers>
            <add autogenerateschema="true" connectionStringName="DefaultConnection" name="DefaultMembershipProvider" type="MySql.Web.Security.MySQLMembershipProvider, MySql.Web, Version=6.9.9.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d" />
          </providers>
        </membership>
        <compilation debug="true"><assemblies><add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" /></assemblies></compilation>
        <authentication mode="Forms">
          <forms loginUrl="Login.aspx" name="adAuthCookie" timeout="10" path="/"></forms>
    
        </authentication>
    
        <authorization>
          <allow roles="Soporte" />
          <allow roles="Administrador" />
          <allow roles="Usuario" />
          <deny users="*" />
    
        </authorization>
    
        <sessionState mode="InProc" timeout="10" customProvider="DefaultSessionProvider">
          <providers>
            <add name="DefaultSessionProvider" type="System.Web.Providers.DefaultSessionStateProvider, System.Web.Providers, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" />
    
          </providers>
        </sessionState>
      <membership defaultProvider="MySQLMembershipProvider">
          <providers>
            <remove name="MySQLMembershipProvider" />
            <add name="MySQLMembershipProvider" type="MySql.Web.Security.MySQLMembershipProvider, MySql.Web, Version=8.0.8.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d" connectionStringName="LocalMySqlServer" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" applicationName="/" requiresUniqueEmail="false" passwordFormat="Clear" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="1" passwordAttemptWindow="10" passwordStrengthRegularExpression="" />
          </providers>
        </membership><profile defaultProvider="MySQLProfileProvider">
          <providers>
            <remove name="MySQLProfileProvider" />
            <add name="MySQLProfileProvider" type="MySql.Web.Profile.MySQLProfileProvider, MySql.Web, Version=8.0.8.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d" connectionStringName="LocalMySqlServer" applicationName="/" />
          </providers>
        </profile><roleManager defaultProvider="MySQLRoleProvider">
          <providers>
            <remove name="MySQLRoleProvider" />
            <add name="MySQLRoleProvider" type="MySql.Web.Security.MySQLRoleProvider, MySql.Web, Version=8.0.8.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d" connectionStringName="LocalMySqlServer" applicationName="/" />
          </providers>
        </roleManager><siteMap defaultProvider="MySqlSiteMapProvider">
          <providers>
            <remove name="MySqlSiteMapProvider" />
            <add name="MySqlSiteMapProvider" type="MySql.Web.SiteMap.MySqlSiteMapProvider, MySql.Web, Version=8.0.8.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d" connectionStringName="LocalMySqlServer" applicationName="/" />
          </providers>
        </siteMap><webParts>
          <personalization defaultProvider="MySQLPersonalizationProvider">
            <providers>
              <remove name="MySQLPersonalizationProvider" />
              <add name="MySQLPersonalizationProvider" type="MySql.Web.Personalization.MySqlPersonalizationProvider, MySql.Web, Version=8.0.8.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d" connectionStringName="LocalMySqlServer" applicationName="/" />
            </providers>
          </personalization>
        </webParts></system.web>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="EntityFramework" publicKeyToken="b77a5c561934e089" culture="neutral" />
            <bindingRedirect oldVersion="0.0.0.0-5.0.0.0" newVersion="5.0.0.0" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
      
    </configuration>

    


    Beimer Osorio

    viernes, 15 de septiembre de 2017 23:19

Respuestas

  • hola

    fijate que en el config defines

    <membership defaultProvider="DefaultMembershipProvider">

    y

    <membership defaultProvider="MySQLMembershipProvider">

    estan duplicada la configuracion, solo dbeerias dejar una de estas secciones

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    lunes, 18 de septiembre de 2017 14:48

Todas las respuestas

  • hola

    fijate que en el config defines

    <membership defaultProvider="DefaultMembershipProvider">

    y

    <membership defaultProvider="MySQLMembershipProvider">

    estan duplicada la configuracion, solo dbeerias dejar una de estas secciones

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    lunes, 18 de septiembre de 2017 14:48
  • Hola Leandro

    De antemano muchísimas gracias por tu apoyo

    he quitado las referencias duplicadas y efectivamente se ha eliminado el error sin embargo sigo sin poder entrar al administrador de asp.net o poder usar el membership de la app, ahora tengo este error, me lo muestra al intentar usar el loguin y o cuando ingreso al adminstrador de asp.net/seguridad


    Beimer Osorio

    miércoles, 20 de septiembre de 2017 22:35