none
¿Web Services lentos o bloqueados? RRS feed

  • Pregunta

  • Buenas tardes,

    Resulta que en días pasados realicé una aplicación de escritorio que se conecta por webservicea una base de datos y ejecuta y realiza consultas.

    Hasta ayer todo iba bien pero ahora que hay mucha gente utilizando la aplicación el webservice no responde se está bloqueando con algo tan sencillo como hacer el login en la aplicacion de escritorio.

    ¿Que debería hacer?

     

    Gracias,

     


    La tecnologia te envuelve
    jueves, 15 de septiembre de 2011 20:43

Todas las respuestas

  • Buenas tardes,

    Resulta que en días pasados realicé una aplicación de escritorio que se conecta por webservicea una base de datos y ejecuta y realiza consultas.

    Hasta ayer todo iba bien pero ahora que hay mucha gente utilizando la aplicación el webservice no responde se está bloqueando con algo tan sencillo como hacer el login en la aplicacion de escritorio.

    ¿Que debería hacer?

     

    Gracias,

     


    La tecnologia te envuelve


    hice la prueba de ejecutar el webservice directamente desde internet explorer y me cargo los datos en xml correctamente....

    No sé que más hacer.

     

    Gracias,


    La tecnologia te envuelve
    jueves, 15 de septiembre de 2011 20:58
  • Hola, si desde el navegador te responde rapido, ¿has revisado lo que hace la aplicacion que 'lee' de ese servicio web ?...

    Tuve un caso que el sw devolvia bien los datos (un datatable) pero la aplicacion cliente (la que tiraba del sw) se hacia un lio y nooperaba bien con esos datos....

    En fin...ya nos contaras...

    Por cierto, iba a publicar una duda: ¿como cambiar dinamicamente la url de un sw?, en decir en desarrollo apunta a http://127.0.0.1/loquesea.asmx y luego cuando publico la aplicacion deberia ser http://xx.xx.xx.xx/loquesea.asmx.

    Se que puedo cambiar el web.config, pero ¿es posible cambiar la url del sw con codigo?.

    Jesus Daryanani - GOPI

    sábado, 17 de septiembre de 2011 17:50
  • Tuve el mismo problema la solución que le dimos a nuestra aplicación fue destruir todas las conexiones dataset y datatable después de su uso con close y dispose
    lunes, 10 de abril de 2017 23:05