none
Error en las referencias de un proyecto RRS feed

  • Pregunta

  • Hola.

    A ver si alguien me da una pista.

    Me he descargado un proyecto de un GIT del trabajo, Lo clono, lo abro con VisualStudio (he probado 2019 y 2017), y todas las referencias aparecen en amarillo.

    Intento volver a cargarlas a mano, y nada. Parece que no dan error, pero vuelven a estar en amarillo y no me deja usarlas.

    Con  los nuguets, lo mimos.. no hay forma.

    Y nada, por mas que actualizo, o restauro los paquetes Nuguets, pasa lo mismo.

    Los quito y los vuelvo a poner o los actualizo, y siguen apareciendo con el warning, y por supuesto, no me deja usarlos.

    Y el mismo error al compilar-

    viernes, 3 de abril de 2020 12:53

Todas las respuestas

  • Hola

     

    Gracias por levantar tu consulta en los foros de MSDN. Estamos analizando su pregunta y vamos a darle seguimiento para buscar la mejor repuesta pertinente al caso.

     

    Gracias por usar los foros de MSDN.

     


    Oscar Navarro

     ____

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

     

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

     

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    viernes, 3 de abril de 2020 13:38
    Moderador
  • hola

    >>todas las referencias aparecen en amarillo.

    que tipo de referencias? porque si son de packetes nuget eso esta corrrecto, solo debes compilar para forzar la descarga

    >>Y nada, por mas que actualizo, o restauro los paquetes Nuguets, pasa lo mismo.

    no tienes que restaurar nada, solo compila y los paquetes nuget se descargan solos

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    viernes, 3 de abril de 2020 14:08
  • Hola Leandro, Gracias por la respuesta.

    Aparecen en amarillo todas, las de paquetes nuget y las normales.

    Si quito la referencia y la vuelvo a poner a mano, ya sea desde el administrador de nuguet o en añadir referencia, vuelven a aparecer en amarillo.

    Si las actualizo, lo mismo.

    Y, por supuesto, al compilar, falla en todas las referencias, pues me dice que faltan todas ellas..

    Seguro que es algo en la configuración del Proyecto (cuando se guardo en el GIT), pero no doy con que.

    sábado, 4 de abril de 2020 7:41
  • hola

    >>Aparecen en amarillo todas, las de paquetes nuget y las normales.

    que esten en amarillo eso es normal que suceda en un principio, pero hay que diferenciar a que llamas normales

    Cuando las referencias normales son referencia a proyectos en la misma solucion? si es asi lo realizas por medio del proyecto o buscando la dll en el la carpeta \bin?

    Si creas un proyecto de cero, no se un winform por ejemplo y agregas alguna de estas librerias nuget, se descarga al compilar?

    >>Seguro que es algo en la configuración del Proyecto (cuando se guardo en el GIT), pero no doy con que.

    git no tiene nada que ver

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    sábado, 4 de abril de 2020 12:39
  • que tal amigo buenas tardes.

    En mi  caso suele pasarme muchas veces ese problema, la nera de resolverlo es:

    1. Click derecho en el nombre de tu proyecto

    2.- del menú que te aparece buscar abrir carpeta en el explorador de archivos.

    3.- buscar una carpeta con el nombre ".vs", en caso de que no este intenta mostrar los archivos olutos.

    4.- Elimina esa carpeta con el proyecto cerrado en visual

    5.- abre tu proyecto y vuelve a compilat


    Horacio Xochitemol Bautista

    domingo, 5 de abril de 2020 17:03
  • Hola , 

      

    ¿Alguna novedad sobre la consulta realizada? ¿Han sido útiles las  respuestas proporcionadas?  

     

    Espero su respuesta. 

      

    Cualquier duda referente a productos Microsoft, puedes consultarnos. Es un gusto informarte. 

    Gracias por usar los foros de MSDN. 

      

    Oscar Navarro

      

     ____ 

      

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.   

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.    

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft. 

    lunes, 6 de abril de 2020 16:50
    Moderador
  • No, la verdad es que no. 

    supongo que seria algún problema del que subió el proyecto al GIT.

    He conseguido un persona que lo tenia en local, y me ha compartido la solución y ya la he podido compilar. Ahora la subiré de nuevo al GIT y listo.

    Muchas gracias en cualquier caso.

    lunes, 6 de abril de 2020 17:55