none
Error al crear tabla en sql server 2005 RRS feed

  • Pregunta

  • Hola a todos, soy nuevo en el foro y tengo un problema que no se solucionar:

    Estoy trabajando con visual basic.net 2005 y sql server 2005.

    Estoy intentando crear una base de datos desde Visual basic en sql server mediante codigo.

    Creo la B.D. y luego dentro de ella las tablas:

    Para crear la B.D. utilizo la siguiente linea de conexion: "server=.\SQLEXPRESS;database=Master;Trusted_Conne ction=True"
    al crear la B.D. no tengo problema. El problema viene al crear la primera tabla. Esta es la linea de conexion que utilizo para crear la tabla:
    "server=.\SQLEXPRESS;database=prueba;Trusted_Connection=True"
    Pero al intentar crearla me sale el siguiente error:

    "Error en el nivel de transporte al enviar la solicitud al servidor .(provider: Proveedor de memoria compartida,error: 0 - No hay ningún proceso en el otro extremo de la canalización.) "

    No tengo ni idea del problema, he intentado buscar información, pero no encuentro nada. Me da a mi que sera que la conexion se corta pero so se....

    Gracias a todos
    • Cambiado Enrique M. Montejo lunes, 2 de mayo de 2011 15:40 acceso a datos (De:Lenguaje VB.NET)
    miércoles, 2 de abril de 2008 11:02

Todas las respuestas

  •  

    Hola,

     

    Primero... con "server=.\SQLEXPRESS;database=Master;Trusted_Conne ction=True" no estas creando la base de datos.

     

    Eso es la cadena de conexion con la que te vas a conectar y segun tu error parece obvio que esta mal construida.

     

    Mas que nada porque por ejemplo estas intentando conectar contra la base Master

     

    te pongo un par de ejemplo de conexion a base de datos donde podras encontrar tambien ejemplo de cadenas de conexion validas:

     

    http://www.moreplus.es/index.aspx?accion=articulo&id=108

     

    http://www.moreplus.es/index.aspx?accion=articulo&id=110

     

    Un saludo

     

     

    Colabora con el foro: Si este mensaje te es de utilidad marcalo como respuesta.

    Javier Conesa

    MCP - Analista Programador

    Web: http://www.moreplus.es/index.aspx


    miércoles, 2 de abril de 2008 13:32
    Moderador
  • Muchas gracias por responderme Javier:

    Si ya lo se, en mi primer mensaje ya ponia que cada una de las lineas de codigo que ponia, eran cadenas de conexion.

    Entonces segun tu, en el parametro database, que tendria que poner???


    He estado investigando un poco mas y  puede ser que el error ese me salga por que sql server me bloque la base de datos que creo y no me deja modificarla de ninguna forma hasta pasado x tiempo.

    Nos e si voy bien encaminado, sigo buscando soluciones.


    Gracias otra vez.



    miércoles, 2 de abril de 2008 16:40