none
Problema al mostrar cubos olap en web con los office web components RRS feed

  • Pregunta

  • Hola, tengo un peuqeño problema a la hora de mostrar un cubo olap que tengo creado, en una pagina con los office web components. El problema es quelos office webs components me los muestra bien, pero a la hora de conectarme con la base de datos de analysis services me indica el siguiente error:

    No se puede procesar la consulta: No se puede conectar al servidor "localhost" no esta en funcionamiento o esta demasiado ocupado.

    A la hora de crear el cubo y de acceder a el desde acces no he tenido ningun problema, es desde los office web components desde donde no puedo acceder... aqui les dejo mi codigo tal cual... pesonalmente creo que es un problema del provider aunque no entinendo exactamente porque... un saludo y espero que me puedan ayudar... gracias...

     

    <HTML>

    <HEAD><meta name="Example 1" contents= "NOINDEX, NOFOLLOW">

    <TITLE>OLAP Number Formats UseProviderFormatting Sample</TITLE>

    <META NAME="GENERATOR" Content="Microsoft Visual Studio">

    <META HTTP-EQUIV="Content-Type" content="text/html; charset=UTF-8">

    </HEAD>

    <BODY bgcolor=lightskyblue text="#000000" link="#006600" vlink="#669966"

    alink="#990000">

    p>

    <button ONCLICK=Connect_OnClick() ID=Button1>Connect</button><p>

    <OBJECT CLASSID="clsid:0002E552-0000-0000-C000-000000000046" id="MyPT" VIEWASTEXT>

    </OBJECT>

    <script language=VBScript>

    function Connect_OnClick()

    MyPT.ConnectionString = "Provider=msOLAP.2;Data Source=localhost;Initial Catalog=<nombre base de datos de Analysis Services>"

    MyPT.DataMember = "<Nombre del cubo>"

    ' Put measures on the view.

    MyPT.CommandText = "select AddCalculatedMembers(Measures.members) on columns from [ <nombre del cubo> ]"

    ' Set the UseProviderFormatting property to TRUE.

    ' This will result in measures being displayed as left justified text.

    MyPT.ActiveView.UseProviderFormatting=true

    end function

    </script>

    </BODY>

    </HTML>

    • Cambiado Gustavo Larriera miércoles, 25 de noviembre de 2009 17:12 Pregunta acerca de OWC. (De:SQL Server)
    viernes, 28 de diciembre de 2007 8:30