none
Problema al exportar informe con Report Viewer RRS feed

  • Pregunta

  • Buenas tengo el siguiente inconveniente al exportar un reporte a excel o pdf con un control ReportViewer, cuando le doy a la opción de exportar me abre una nueva pestaña diciendo que el servidor no a devuelto datos, gracias por la ayuda que me puedan brindar.
    martes, 11 de septiembre de 2012 14:05

Todas las respuestas

  • Revisa que el código con el que asignas el origen de datos a tu reporte no este dentro de esto:

          protected void Page_Load(object sender, EventArgs e)
          {
                if (!IsPostBack)
                {
                  //Aqui no debes de asignar el origen de datos.
    
                }
    
    
              //Aquí si ;)
    
          }


    Un saludo, Cristian Pérez

    martes, 11 de septiembre de 2012 15:55
  • Hola cristian gracias por responder. Hay un detalle con el código y es que la aplicación ya esta compilada y por ende el código fuente no lo tenemos. Es un error super extraño por que cuando se reinicia el servidor la falla desaparece por un tiempo pero luego vuelve a generarse. No se si es que algún recurso que utiliza la aplicación se congestiona o algo por el estilo.
    lunes, 24 de septiembre de 2012 21:56
  • Siendo ese el caso, lo único que se me ocurre es que sean problemas de red que se presentan ocacionalmente especificamente de comunicación entre aplicación y base de datos.

    Pero si es muy extraño el comportamiento.


    Un saludo, Cristian Pérez

    lunes, 24 de septiembre de 2012 21:59