none
Error 40 SqlServer 2005 al desplegar un WebPart RRS feed

  • Pregunta

  • Hola, hace muy poco empece a programar en c# y ahora estoy intentando hacer un web part sencillo para después armar uno más complejo que necesito. El problema es el siguiente: al hacer ctrl F5 (utilizo el visual studio 2005) para poder verlo en el explorador me da el siguiente error: Error mientras se establecía la conexión con el servidor. Al conectar con SQL Server 2005, el error se puede producir porque la configuración predeterminada de SQL Server no admite conexiones remotas. (provider: Proveedor de canalizaciones con nombre, error: 40 - No se pudo abrir una conexión con SQL Server).
    Lo que hicimos fue esto: en la parte de diseño de una aspx arrastrastrar el control webpartmanager, despues el webpartzone y ahi poner un mensaje (queria un grid pero como daba este problema probe con esto mas simple), cuando lo corro para verlo me da ese error. En otros foros indica ir a la configuracion de superficie del sql server, habilitar la opcion de permitir conexiones remotas, lo hicimos reiniciamos el servicio pero no hay forma de que deje de aparecer esto.
    Como veran el web part es sumamente sencillo, queria saber si para poder visualizarlos en el explorador como cualquier otro asp es necesario configurar algo más.
    Necesito resolver esto urgente, les agradezco cualquier sugerencia ya que como les comentaba mi experiencia en .net es sumamente limitada.
    Muchas gracias.
    lunes, 20 de abril de 2009 15:02

Todas las respuestas

  • hola,

    A la base de datos se estan pudiendo conectar desde el "Sql Server Manager Studio" ? me refuero desde otra pc.

    O han probado crear un pequeño winform, que solo realice la conexion a la db? digo solo para descartar que no se un problema de conexion del webpart.

    Una consulta, comenta que estas utilziando VS 2005, pero el SQL Server, es 2005, 2008, Developer, Professional, Express ?


    Saludos
    Leandro Tuttini
    lunes, 20 de abril de 2009 15:31
  • Hola, gracias por haber leido mi consulta.
    Mira dentro dentro del proyecto donde creamos el webpart que te comentamos hay otros asp que tienen por ejemplo grids en este caso muestra datos correctamente, el error lo da solamente cuando queremos desplegar el webpart ya sea le pongamos solo un mensaje de texto o algun otro control dentro (esto ultimo es lo que necesitamos pero como daba este error solo probamos con un mensaje pero tampoco funciona). Por eso creiamos que se trataba de que faltaba algun tipo de configuracion por ser un webpart ya que con los demas controles de .net no nos dan este tipo de excepciones.
    Estamos usando las versiones express ya que como se trata de un proyecto de estudio no contamos con licencias, el visual studio y el sql son las versiones 2005.
    Muchas gracias, saludos.
    Evelyn.
    lunes, 20 de abril de 2009 17:20