none
Videos o mapas en columna 'HTML para publicación' RRS feed

  • Pregunta

  • Buenos días, estoy intentando poner un vídeo y un mapa en una columna de tipo 'HTML para publicación' y al guardar me elimina el código. Respecto al vídeo se trata de uno de Youtube, he probado de la manera actual (iframe) y de la antigua (object) pero de ninguna forma me deja. Evidentemente estoy pegando el código en el editor HTML que tiene. Alguien ha tenido este problema a similar y podría ayudarme? Muchas gracias
    lunes, 17 de octubre de 2011 15:10

Respuestas

  • Hola de nuevo.

    Te adjunto las imágenes para que veas el ejemplo paso a paso.

    • PASO 1: Insertar un Content Editor Web Part
    • PASO 2: Editar el contenido HTML
    • PASO 3: Poner el script y guardar.
    • PASO 4: Guardar los cambios de la página, e volià!


    "En los momentos de crisis, sólo la imaginación es más importante que el conocimiento"
    • Marcado como respuesta VWeb lunes, 7 de noviembre de 2011 16:15
    lunes, 7 de noviembre de 2011 15:27
    Moderador

Todas las respuestas

  • Hola.

    El campo de tipo "Texto enriquecido" (Rich Text) convierte los caracteres especiales como "<", "&" en su codificación HTML, con lo que probablemente se esté comiendo muchas cosas. Prueba a seleccionar el campo HTML, y en la Ribbon ir a "HTML -> Editar fuente HTML", se te abrirá un popup donde podrás insertar tu código. Guarda los cambios, guarda la página y comprueba si de esta forma consigues visualizarlo.


    "En los momentos de crisis, sólo la imaginación es más importante que el conocimiento"
    lunes, 17 de octubre de 2011 16:14
    Moderador
  • Hola Santiago, es de tipo 'HTML para publicación', si mal no recuerdo es en 'Varias líneas de texto donde te permite lo que dices de texto enriquecido. De todas formas ahora mismo estoy haciendo eso que comentas, le doy al editor HTML y ahí es donde pego el código, pero al guardar lo borra...es más si le doy al botón de debajo, el de Convertir a XHTML también me lo quita, alguna solución? Gracias
    lunes, 17 de octubre de 2011 22:09
  • Esto mismo lo comenté en un post anterior. Cuando guardas, no verás el código. Digamos que... se "incrusta" en la página porque, no olvidemos que es código html. 

    Entonces, al aceptar en la ventana de vista HTML, no verás nada directamente, pero al guardar la página, debería verse el resultado.

     

    Otra forma es que insertes un HTML Form WebPart y sustituyas su contenido HTML por lo que quieres poner.

     


    "En los momentos de crisis, sólo la imaginación es más importante que el conocimiento"

    lunes, 17 de octubre de 2011 22:26
    Moderador
  • Después de unos días con otros asuntos vuelvo a este problema, sigo sin funcionar. Introduzco el código embed del vídeo o por ejemplo un javascript y no funciona.

    Supongo que se deberá a esto, cualquier javascript que pongo en un campo de la página, no funciona. Alguien sabría decirme alguna solución? Gracias

    lunes, 7 de noviembre de 2011 15:04
  • Hola de nuevo.

    Te adjunto las imágenes para que veas el ejemplo paso a paso.

    • PASO 1: Insertar un Content Editor Web Part
    • PASO 2: Editar el contenido HTML
    • PASO 3: Poner el script y guardar.
    • PASO 4: Guardar los cambios de la página, e volià!


    "En los momentos de crisis, sólo la imaginación es más importante que el conocimiento"
    • Marcado como respuesta VWeb lunes, 7 de noviembre de 2011 16:15
    lunes, 7 de noviembre de 2011 15:27
    Moderador
  • Muchas gracias Santiago, ya lo he probado y funciona. Gracias! Un saludo
    lunes, 7 de noviembre de 2011 16:15