none
Enterprise Library v5 da error cuando quiero guardar RRS feed

  • Pregunta

  • Tengo un sistema hecho con c# (con .Net 4.0) en 3 capas, tengo una capa Comunicacion que es donde tengo la clase Linq to Sql, ahí me crea el archivo app.config con la cadena de conexión al Sql Server, a este archivo lo quiero encriptar con Enterprise Library, cuando le doy guardar me da este error:

    Se ha producido un error al ejecutar el controlador de sección de configuración para connectionStrings

    ¿Cómo lo puedo solucionar?

    lunes, 21 de mayo de 2018 10:52

Todas las respuestas

  • Hola ,

    En realcion a tu consulta, ¿Pudiste resolverlo? ¿Encontraste una solucion?

    Quedo al pendiente de tus comentarios.

    Saludos cordiales

    Gracias por usar los foros de MSDN

    Tonatiuh Abrego

    _____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. 

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    jueves, 24 de mayo de 2018 21:24
    Moderador
  • No encontré ninguna solución, estoy esperando su respuesta
    viernes, 25 de mayo de 2018 14:54
  • Muestre su config porque muy difícilmente puede uno darle alguna solución cuando se está completamente a ciegas.

    Le aclaro que nunca he encriptado datos en el config, pero soy bien capaz de encontrar documentación como esta.


    Jose R. MCP
    My GIT Repositories | Mis Repositorios GIT

    viernes, 25 de mayo de 2018 16:29
    Moderador
  • <?xml version="1.0"?>
    <configuration>
        <configSections>
        </configSections>
        <connectionStrings>
            <add name="Comunicacion.Properties.Settings.respatConnectionString"
                connectionString="Data Source=localhost;Initial Catalog=respat;Integrated Security=True"
                providerName="System.Data.SqlClient" />
        </connectionStrings>
    </configuration>
    Este es el código de mi app.config, cabe aclarar que lo tenía encriptado y lo borré y lo volví a generar sin encriptar.
    viernes, 25 de mayo de 2018 16:59
  • Ya encontré la solución, en el archivo Settings.settings había que hacer clic en Sincronizar
    viernes, 25 de mayo de 2018 17:35