none
problema con el global.asax RRS feed

  • Pregunta

  •  

    Tengo un problema con este archivo,creo que es el problema. He montado ya la aplicación en un servidor con IIS, pero cuando lo ejecuto, tengo que hecho en el global.asax una funcion llamada :

    void Application_BeginRequest(object sender, EventArgs e)

     

    pero por lo que sea cuando se supone que tiene que entrar no entra como cuando lo ejecuto en local.

     

    Que tengo que activar para que se active el global.asax?

     
    martes, 20 de mayo de 2008 9:58

Todas las respuestas

  •  

    Hola,

     

    todas las aplicaciones ASP.NET pasan por el Application_Begin del global.asax durante su rimera ejecución.

     

    muy probablemente no tengas bien instalada la versión del framework correspondiente o tengas algun tipo de problema de configuración.

     

    que error te da exactamente??

     

    saludos.

     

    Colabora con el foro: Si este mensaje te es de utilidad marcalo como respuesta.

    Javier Conesa

    MCP - Analista Programador

    Web: http://www.moreplus.es/index.aspx


    martes, 20 de mayo de 2008 11:21
  • Salir no me sale ningun error pero no hace lo que deberia te explico.

     

    En local cuando lo arranco con el F5, me sale la direccion tipica http:/ local host....../index.htm

    Lo que tengo hecho es que si en vez de index.htm pongo un nombre, pro ejemplo raul pues va a una pagina y recojo la variable dnd esta raul, para utilizarla en el formulario siguiente.(esto lo tengo hecho en el metodo ese de global asax)

     

    Cuando lo tengo subido ya al servidor y lo arranco, pues intento hacer eso y me salta a la pagina de error, vamos que no utiliza el global.(Por una parte proque me sale http:/123.232......../WEB/, y no me sale /WEB/index.htm como en otra aplicacione sque hay en el servidror colgadas)(siento si me he expresado mal, pero toy en el curro y tengo que escribir mu rapido espero que haya quedado algo claroSmile)

     

    Por ahi he leido que hay q activar este archivo, pero desconozco como. De todas formas lo de los frameworks puede ser el problema porque en el servidor esta el 1.1 y yo tengo el 2.0. Pero como me parece algo tan raro no se si es solo de eso. MUchas gracias 

    martes, 20 de mayo de 2008 12:04
  • Hola,

     

    el global.asax no deberia usarse para ese tipo de cosas...

     

    por este archivo solo se pasa la primera vez que se ejecuta la aplicacion.

     

    en local cada vez que le das al play y paras estas iniciando la aplicacion y parandola... pero en un servidor IIS no ocurre eso a no ser que reinicies el servicio con iisreset en "inicio-ejecutar"

     

    de todas maneras obviamente que en el servidor tengas el .net 1.1 y estes compilando en el 2.0 puede traerte muchos problemas.

     

    saludos.

     

    Colabora con el foro: Si este mensaje te es de utilidad marcalo como respuesta.

    Javier Conesa

    MCP - Analista Programador

    Web: http://www.moreplus.es/index.aspx

    martes, 20 de mayo de 2008 12:14