none
Error vrfcore.dll y error al establecer jitDebugging="true" RRS feed

  • Pregunta

  • Hola:

    Tengo un error con Jit, es decir desde que se instalo el Jit, me empezaron aparecer errores, antes funcionaba todo correctamente:

    Primero cambio la pantalla de error y salía Just In Time y si quería iniciar la depuración desde visual basic net. Luego busque información en internet y me decía que para activar o desactivar el control de errores debía insertar el siguiente código en <system.windows.forms jitdebbuging="true" />, al hacerlo me decía que no podía leer el resto de configuración, es decir todo lo que escribiera después de esa línea no leía, y provocaba un error en tiempo de ejecución "Error en el sistema de inicialización de configuración".

    Si ejecuto la aplicación en Debug no hay problemas, En Release a veces funciona y a veces No, y si ejecuto desde publicar para probar la instalación, instala la aplicación, la ejecuta, y justo en el momento de ejecutar aparece "Se ha encontrado un error en la aplicación y Windows esta buscando una solución al problema, pero aunque ponga la variable jitDebugging da igual como si no existiera, pero si consulto el visor de eventos de Windows aparecen los datos del error:

    - System
    - Provider
    [
    Name]
    Application
    Error
    - EventID 1000
    [
    Qualifiers]
    0
    Level 2
    Task 100
    Keywords 0x80000000000000
    - TimeCreated
    [
    SystemTime]
    2015-12-19T20:59:52.000000000Z
    EventRecordID 18435
    Channel Application
    Computer
    Security
    - EventData
    Tarot
    2.exe
    2.0.0.0
    5675a14b
    vrfcore.dll
    10.0.10240.16384
    559f3a9e
    80000003
    000037a1
    9c8
    01d13aa0321665a2
    C:\Users\Jhonny\AppData\Local\Apps\2.0\HAE4PW9W.K5Y\P2Z6MP6P.35W\taro..tion_97c55f4038597ecf_0002.0000_7d81be2a639d5fac\Tarot
    2.exe
    C:\Windows\SYSTEM32\vrfcore.dll
    727a0253-a693-11e5-b1fc-001e682022ab




    • Editado SuperMagus jueves, 24 de diciembre de 2015 2:43
    jueves, 17 de diciembre de 2015 18:47

Respuestas

  • Solucionado!! este error del vfrcore.dll después de buscar por todo internet hasta que encontré la respuesta mirando un montón de sitios. Esta es la solución, por lo visto era esta aplicación instalada en el sistema, para verificar la aplicación, y no la validaba, así que no la dejaba ejecutarse:

    APPVERIF.exe (en mi caso se llama así, ejecutando un "dir appver*.* en el directorio c:\windows\System32") o APPVERIFIER.exe depende del sistema operativo, ejecutamos la aplicación desde la línea de comandos cmd.exe o desde el explorador de Windows, buscamos nuestra aplicación y desmarcamos todos las casillas de verificación, y cuando volvemos a publicar nuestro proyecto y ejecutar el setup de  la instalación se instala y ejecuta nuestra aplicación con normalidad!!.

    Texto Original en inglés: "I've searched Appverifier.exe and unchecked all for myapp.exe. Its on C:\Windows\System32. I've done the apppackage and it pass the App verifier test for store.  Soo problem resolved! I'm soo happy today"

    Pagina web de donde encontré  la respuesta: "forum.unity3d.com/th reads/error-debbuging-the-app-on-visual-studio-2013-professional-update-3.272109"

    Nota: aun no puedo poner ni imágenes ni vínculos como pretendía, porque me dice que no han verifcado mi cuenta.. :(

    • Marcado como respuesta SuperMagus jueves, 24 de diciembre de 2015 1:40
    jueves, 24 de diciembre de 2015 1:40

Todas las respuestas

  • Añado mas información, intente ejecutar la aplicación desde la capeta release, y modifique el archivo App.config dentro de esa carpeta NO dentro del ide, y me funcionó parcialmente, es decir al poner dentro de App.config

    <system.windows.forms jitdebuging="true" />

    si lo pongo justo debajo de

    <configuration>

    me provoca un error y me dice que el primer elemento después de <configuration> debe ser <configSection>, y aparece un error que dice "Error de inicialización del la configuración", si lo coloco en cualquier otra parte del App.config aunque funcione el código para el Jit, lo que hace es invalidar el resto del documento, todo lo que este después de la línea <system.windows.forms jitdebuging="true" />, automáticamente queda invalidado,.

    Si lo hago desde el IDE, entonces me aparece en Lista de resultados: "No se encontró el esquema de ..." y aquí cualquier elemento que este debajo del <system.Windows.forms jitdebuging="true" />, y aunque lo ponga al final del documente antes del cierre de </configuration>, no surte efecto sobre JIT, y encima sigue siendo invalido el documento XML.

    También probé una solución que encontré en foros por internet que era después de guardar el documento App.config que era ir al menú XML, y decirle que cree el esquema de nuevo, pero tampoco funciona.

    domingo, 20 de diciembre de 2015 11:25
  • Solucionado!! este error del vfrcore.dll después de buscar por todo internet hasta que encontré la respuesta mirando un montón de sitios. Esta es la solución, por lo visto era esta aplicación instalada en el sistema, para verificar la aplicación, y no la validaba, así que no la dejaba ejecutarse:

    APPVERIF.exe (en mi caso se llama así, ejecutando un "dir appver*.* en el directorio c:\windows\System32") o APPVERIFIER.exe depende del sistema operativo, ejecutamos la aplicación desde la línea de comandos cmd.exe o desde el explorador de Windows, buscamos nuestra aplicación y desmarcamos todos las casillas de verificación, y cuando volvemos a publicar nuestro proyecto y ejecutar el setup de  la instalación se instala y ejecuta nuestra aplicación con normalidad!!.

    Texto Original en inglés: "I've searched Appverifier.exe and unchecked all for myapp.exe. Its on C:\Windows\System32. I've done the apppackage and it pass the App verifier test for store.  Soo problem resolved! I'm soo happy today"

    Pagina web de donde encontré  la respuesta: "forum.unity3d.com/th reads/error-debbuging-the-app-on-visual-studio-2013-professional-update-3.272109"

    Nota: aun no puedo poner ni imágenes ni vínculos como pretendía, porque me dice que no han verifcado mi cuenta.. :(

    • Marcado como respuesta SuperMagus jueves, 24 de diciembre de 2015 1:40
    jueves, 24 de diciembre de 2015 1:40