none
Como incluir Strsafe.h a C++ RRS feed

  • Pregunta

  • Compilo un código que tiene esa cabecera , y me bota un error que me dice q no halla ese archivo  strsafe.h
    d:\.....\source_threads\source.cpp(3) : fatal error C1083: Cannot open include file: 'strsafe.h': No such file or directory



    lunes, 20 de octubre de 2008 4:52

Todas las respuestas

  • ¿Qué versión de Visual Studio estás utilizando? Porque yo lo tengo en C:\Program Files\Microsoft SDKs\Windows\v6.0A\Include.

     

    ¿Tienes esa ruta incluida en las rutas por defecto de Visual C++? Mira en Herramientas -> Opciones -> Proyectos y Soluciones -> Carpetas de VC++.

     

    ¿Cómo has hecho la inclusión?

     

    #include "strsafe.h"

     

    o

     

    #include <strsafe.h>

     

    La segunda es la correcta para ficheros cabecera estándar.

    lunes, 20 de octubre de 2008 17:22
    Moderador
  • Hola, tengo  Microsoft Visual C++ 6.0, y si en mi codigo esta como la segunda forma, #include <strsafe.h>, busqúe esa carpeta include y la encontré en C:\Archivos de programa\Microsoft Visual Studio\VC98\Include        y no está ese archivo .h strsafe.h ...

    Tambien intenté ir  a 
    Herramientas -> Opciones -> Proyectos y Soluciones -> Carpetas de VC++  pero no veo Proyectos y soluciones, voy a Herramientas->Opciones y veo una ventanita con 12 pestañas : Editor, Tabs, Debug, Compatibility, Build, Directories, Source Control, Workspace, Data View, MAcros, Help System y Format,
    intente buscar carpetas de VC++ per ono lo hallo.

    Disculpa por la demora en mi respuesta. Espero q me ayudes, sería muy util para mi aprender  a agregar cabeceras .h a C++ ..

    Saludos
    martes, 28 de octubre de 2008 3:06
  • Claro que no está. Es que Visual C++ 6.0 es demasiado viejo para ello. Ese fichero se añadió con posterioridad al final de soporte de esa versión de Visual C++, de hecho no podrás ni siquiera copiarla de otro compilador más moderno porque faltan, dentro del propio compilador y del runtime, las cosas necesarias para que eso funcione.

     

    Mi recomendación es que abandones el Visual C++ 6 y te pases a cosas más modernas. Si no puedes/quieres pagar una versión completa de Visual Studio, tienes las versiones Express, que son completamente gratuitas y salvo algunas pequeñas limitaciones, son completamente funcionales.

     

    Las puedes bajar de aquí: http://www.microsoft.com/express/vc/Default.aspx

     

    • Propuesto como respuesta Carles Vila miércoles, 10 de agosto de 2011 9:40
    lunes, 3 de noviembre de 2008 10:56
    Moderador
  • Hola, Gracias ya me instalé el c++ Express.  Pero aun no encuentro esa cabecera, por ejemplo el <thread.h> tampoco me compila, asi como el <strsafe.h> tampoco.

    ------ Operación Generar iniciada: proyecto: thread, configuración: Debug Win32 ------
    Compilando...
    thread.cpp
    c:\documents and settings\elian\mis documentos\visual studio 2008\projects\threads\thread.cpp(3) : fatal error C1083: No se puede abrir el archivo incluir: 'pthread.h': No such file or directory
    El registro de compilación se guardó en el "file://c:\Documents and Settings\Elian\Mis documentos\Visual Studio 2008\Projects\threads\Debug\BuildLog.htm"
    thread - 1 errores, 0 advertencias
    ========== Generar: 0 correctos, 1 incorrectos, 0 actualizados, 0 omitidos ==========


    Y en la ruta Herramientas->Opciones -> Proyectos y soluciones-> Directorios de VC++     dice Plataforma , Mostrar derectorios paraSadlista desplegable que muestra archivos ejecutables, archivos de inclusión, archivos de refrencia, archivos de biblioteca, archivos de código fuente, excluir directorios....)  elegí para archivos de inclusión y aparecen:
    $(VCInstallDir)include
    $(VCInstallDir)atlmfc\include
    $(WindowsSdkDir)\include
    $(FrameworkSDKDir)include

    En esta ruta está mi include C:\Archivos de programa\Microsoft Visual Studio 9.0\VC\include


    No entiendo hasta ahora como incluir las cabeceras que no me compilan.........gracias por su apoyo.......




    jueves, 6 de noviembre de 2008 20:20
  • FORRRRRRRRRRRROOOOOOOOOO A MI ME FUE CON LA PRIMERA OPCION
    domingo, 19 de junio de 2011 2:19