none
Problemas de Inicio de Sesion en SQL desde mi App C# RRS feed

  • Pregunta

  • Hola amigos aca de vuelta, he logrado solucionar el problema de conexión que antes tenia con respecto a mi aplicacion en C# form.

    Al punto: SQL ya no me hace referencia a error 26 de Instancia y Red pero ahora me muestra este error:

    Error de Inicio de Sesión. El inicio de sesión se realiza desde un dominio que no es de confianza y no se puede realizar con autenticación de Windows.

    Así tengo configurado mi SQL

    1)Acceso Remoto y conexión de SQL y Windows.(Listo)

    2)SQL Configuration Manager, Browser activado, y servicios locales configurados, TCP y UDP 1433-1434 (Listo)

    3)Firewall con exception de mi aplicación. (Básicamente Desactivado)

    Mi Instancia es ACSAXPRESS y Uso SQL EXPRESS 2014

    Esta es mi cadena de conexion en APP.config 

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
        <configSections>
        </configSections>
        <connectionStrings>
            <add name="Comercial_SBP.Properties.Settings.AplicacionComercialConnectionString"
                connectionString="Data Source=KEN\ACSAXPRESS;Initial Catalog=AplicacionComercial;User ID=sa;Password=k2016"
                providerName="System.Data.SqlClient" />
        </connectionStrings>
        <startup useLegacyV2RuntimeActivationPolicy="true" > 
            <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5" />
        </startup>
    </configuration>

    La implementacion es de mi app en una pc cliente con DB local. Ya que en mi pc de desarrollo todo me corre al 100% pero al hacer la implementacion en otra pc me da ese error. Gracias de Antemanos.

    Saludos

    Espero puedan ayudarme.

    martes, 15 de noviembre de 2016 0:05

Respuestas

  • Pueden existir varias razones, pero comenzando por lo mas sencillo veamos que hayas descartado:

    1) El modo de seguridad en sql está establecido en Mixto

    2) Prueba creando un nuevo login de sql y dale permisos en tu base de datos para que no uses sa el cual es mapeado en forma automática.

    martes, 15 de noviembre de 2016 7:33

Todas las respuestas

  • Pueden existir varias razones, pero comenzando por lo mas sencillo veamos que hayas descartado:

    1) El modo de seguridad en sql está establecido en Mixto

    2) Prueba creando un nuevo login de sql y dale permisos en tu base de datos para que no uses sa el cual es mapeado en forma automática.

    martes, 15 de noviembre de 2016 7:33
  • Esta bien haré la pruebas... Yo le comento como me fue. Gracias de antemano.
    jueves, 17 de noviembre de 2016 1:22