none
Problema de idioma (LCID) con TFS y Sharepoint RRS feed

  • Pregunta

  • Saludos a todos; resulta que en la oficina hemos estado probando TFS con el fin de adaptar el proceso para en un futuro utilizar esta tecnologia para los desarrollos.

    Instalamos todo: Windows Server 2008 R2 en español, Sharepoint 2010 en Ingles y TFS 2010 en Español. Parecia funcionar todo perfecto, probamos los Process Templates que vienen por defecto en TFS (CMMI y Agil)... perfecto.

     

    Sin embargo, cuando intentamos montar un process template para Scrum, se logro configurar bien el process template como tal, pero el portal de proyecto no se deja crear. Segun leo en los logs de creacion del nuevo proyecto, el problema esta relacionado con el lenguaje. El Template de Sharepoint del tipo de proyecto (scrum) no soporta el idioma de TFS ... o algo así...

     

    Esta es la excepcion lanzada:

    "Mensaje de excepción: TF249033: La plantilla de sitio no está disponible para el identificador de configuración regional (LCID). El nombre de la plantilla de sitio es: SCRUM. El LCID es: 1033. (tipo TeamFoundationServerException)"

    Antes de que esto ocurriera, para hacer algunos ajustes a la colección de sitios, instale los correspondientes LanguajePack para Sharepoint 2010.

     

    Agradezco si alguno me puede orientar para solucionar este problema.

     

    Pd: No puedo instalar TFS en ingles porque mi jefe no me deja.

     

    Cordialmente,

     

    Camilo Bernal

     

     

     

     

     

    jueves, 2 de junio de 2011 18:23

Respuestas

  • Hola Ángel, si como dices el Sharepoint lo instalasteis en Inglés, debería encontrar sin problemas el LCID 1033. De hecho el error tendría más lógica si el Sharepoint estuviese instalado en Español.

    En cualquier caso, puedes probar lo siguiente:

    - Abre el fichero WssTasks.xml de la plantilla (normalmente lo encontrarás en C:\Program Files\Microsoft\Microsoft Visual Studio Scrum 1.0\Process Template\Windows SharePoint Services), y cambia language="1033" a 1034 (Español)

    - Importa de nuevo la plantilla en TFS desde el gestor de plantillas de la colección y prueba a crear un proyecto de nuevo

     

    Espero que sea de ayuda...

     

    Un saludo!!!

     

    viernes, 3 de junio de 2011 17:26
  • Angel buenas,

    una pregunta, ¿seguro que el SharePoint está en Inglés?. La solución de JL debería funcionar, luego nos cuentas que tal lo llevas.

    Saludos


    MVP Team System http://www.elbruno.com
    martes, 7 de junio de 2011 7:05
    Moderador

Todas las respuestas

  • Hola Ángel, si como dices el Sharepoint lo instalasteis en Inglés, debería encontrar sin problemas el LCID 1033. De hecho el error tendría más lógica si el Sharepoint estuviese instalado en Español.

    En cualquier caso, puedes probar lo siguiente:

    - Abre el fichero WssTasks.xml de la plantilla (normalmente lo encontrarás en C:\Program Files\Microsoft\Microsoft Visual Studio Scrum 1.0\Process Template\Windows SharePoint Services), y cambia language="1033" a 1034 (Español)

    - Importa de nuevo la plantilla en TFS desde el gestor de plantillas de la colección y prueba a crear un proyecto de nuevo

     

    Espero que sea de ayuda...

     

    Un saludo!!!

     

    viernes, 3 de junio de 2011 17:26
  • Gracias Jose Luis y Bruno, no se que pasa con las alertas de Social MSDN, pense que nadie habia respondido mi pregunta porque no me habian llegado las alertas, me dio por entrar hoy porque deseo resolver el problema pronto.

     

    Voy a probar la solucion que propone Jose Luis y les comento. Si funciona, marcare sus post como respuesta (como es debido) sino, los seguire molestando.

     

    Como siempre, muchas gracias.

     

    Saludos

    martes, 7 de junio de 2011 13:26
  • Perfecto Amigos, eso era. Solo que tuve que setear el language a  "3082". Ahora me funciona perfecto.

     

    Muchas gracias a todos,

     

    un abrazo,

     

    Camilo Bernal.


    Camilo Bernal Ingeniero de Desarrollo
    martes, 7 de junio de 2011 15:32
  • Bruno un favor yo tengo un problema similar tengo todo instalado en español excepto el tfs, lo malo es que a mi no me deja si quiera configurar en colecciones el sitio de sharepoint por el mismo problema cid del idioma, cual seria la solucion en mi caso? tienes alguna idea?
    martes, 31 de julio de 2012 17:28