none
Apoyo con expresión de ReportViewer para mostrar el saldo de un registro RRS feed

  • Pregunta

  • Que tal, espero pudieran ayudarme con una expresión de report viewer que me trae dando vueltas sin éxito alguno.

    Ocupo mostrar los abonos que ha tenido una factura (Hasta aquí está resuelto) y en base a ello, que el saldo de la factura se vaya actualizando en cada renglón de acuerdo al importe del abono, esto último es lo que no he podido lograr.

    Lo que ocupo es esto:

    Factura   Cargo  FechaFactura  FechaPago  Abono  Saldo

        1         100     15-12-2017    16-12-2017   50       50

                                                     17-12-2017  30        20


    En el campo de la columna Saldo tengo la siguiente expresión

    =Fields!cargorem.Value Previous(Sum(Fields!importe.Value)-Fields!importe.Value)

    el campo Fields!Importe.Value corresponde a la columna abono.

    Lo que pretendía lograr con esta expresión era que sumara el total de la factura menos la suma de los campos de importe previos, menos el importe del abono del renglón y así ir obteniendo un saldo. Pero lo que obtuve es:

    Factura   Cargo  FechaFactura  FechaPago  Abono  Saldo

        1         100     15-12-2017    16-12-2017   50       100

                                                     17-12-2017  30        100

    Me está poniendo el saldo de la factura igual al cargo :(


    Cabe mencionar que la columna saldo no tiene relacionado ningún campo de la tabla de mi base de datos, solo la agregué para mostrar ahí el dato.

    Espero pudieran orientarme sobre qué corregir de mi expresión actual para llegar al resultado deseado.

    Muchas gracias por el tiempo que dediquen a responder mi consulta.


    • Editado Joan_23 jueves, 21 de diciembre de 2017 19:07
    • Cambiado Enrique M. Montejo lunes, 25 de diciembre de 2017 10:06 Pregunta relacionada con el control de informes de Windows Forms.
    jueves, 21 de diciembre de 2017 19:02

Todas las respuestas

  • Hola Joan_23

    De acuerdo a tu consulta, te recomiendo revisar tus stores en SQL, es decir como estás llamando a los datos, así como también te recomiendo que revises tu editor SAP Crystal Reports. Muchas veces este tipo de errores se dan debido a como estamos editando los reportes.

    Quedamos al pendiente de cualquier actualización de tu parte.

    Saludos Cordiales y felices fiestas.

    Gracias por usar los foros de MSDN.

    Pablo Rubio
     _____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    jueves, 21 de diciembre de 2017 22:21
  • Gracias por tomarse el tiempo de responder Moderador Pablo Rubio. Traté de ser lo más explicito posible en mi pregunta pero tal parece que aún así no me di a entender. No estoy usando Crystal Reports sino Report Viewer, el dato que no logro que se muestre correctamente no lo estoy trayendo directamente de la base de datos sino lo debo obtener a partir de un cálculo en el reporte, por eso puse cómo tengo actualmente la expresión que me está dando problema.

    Mi duda y detalle es únicamente con la expresión, no con stores ni mucho menos.

    Gracias, espero que puedan apoyarme al respecto.

    • Propuesto como respuesta Pablo Rubio jueves, 21 de diciembre de 2017 23:39
    • Votado como útil Enrique M. Montejo sábado, 23 de diciembre de 2017 12:49
    jueves, 21 de diciembre de 2017 22:38
  • Gracias por tomarse el tiempo de responder Moderador Pablo Rubio. Traté de ser lo más explicito posible en mi pregunta pero tal parece que aún así no me di a entender. No estoy usando Crystal Reports sino Report Viewer, el dato que no logro que se muestre correctamente no lo estoy trayendo directamente de la base de datos sino lo debo obtener a partir de un cálculo en el reporte, por eso puse cómo tengo actualmente la expresión que me está dando problema.

    Mi duda y detalle es únicamente con la expresión, no con stores ni mucho menos.

    Gracias, espero que puedan apoyarme al respecto.

    Hola tengo el mismo problema, lo pudiste solucionar?

    Gracias

    viernes, 20 de abril de 2018 16:50