none
Problema con asp.net y xml RRS feed

  • Pregunta

  • Hola a todos, estoy arrastrando un problema hace tiempo el caso es al leer un xml de un proveedor distinto ( webservice ) utilizando XPathDocument y XPathNavigator

     

    Dim myXPathDocument As System.Xml.XPath.XPathDocument = New System.Xml.XPath.XPathDocument(url)

    Dim myNavigator As System.Xml.XPath.XPathNavigator = myXPathDocument.CreateNavigator()

     

    Todo sale muy bien y muestra bien el resultado, pero en cierto momento los resultados del xml que me muestra son otros y no los que yo pedí al parecer se cruza la respuesta del xml, para solucionar este problema reemplazo mis dll de la carpeta /binn (los vuelve a pegar) y funciona de nuevo bien, nose que mas hacer.

     

    Gracias por su ayuda

    miércoles, 18 de abril de 2007 23:01

Todas las respuestas

  • Hopla compañero:

     

    Has probado a actualizar la referencia Web de los WebServices???

     

    Salu2

     

    Colabora con el foro: Si la respuesta te es de utilidad marca la pregunta como respondida.

    Luis Ruiz Pavón

    MCP

    Blog: http://geeks.ms/blogs/lruiz

    jueves, 19 de abril de 2007 6:32
  • Gracias por tu respuesta, pero no utilizo la referencia web la forma como lee el xml es la siguiente:

     

    Dim url as string = “http://miproveedor.com/listaarchivos.xml”
    Dim myXPathDocument As XPathDocument = New XPathDocument(url)
    Dim myNavigator As XPathNavigator = myXPathDocument.CreateNavigator()

    jueves, 19 de abril de 2007 17:40
  • Pero entonces tu proveedor no es un webservice Wink

     

    Como veo que estas leyendo de una ruta de internet te pueden venis los problemas por la caché, no???

     

    Salu2

     

    Colabora con el foro: Si la respuesta te es de utilidad marca la pregunta como respondida.

    Luis Ruiz Pavón

    MCP

    Blog: http://geeks.ms/blogs/lruiz

    viernes, 20 de abril de 2007 6:41