none
error en cadena de conexión vb.net a azure con sql server RRS feed

  • Pregunta

  • Hola a todos:

    Tengo un problema al intentar conectar desde vb.net (app.config) a una base situada en Azure. Desde el management studio ya he logrado situar la base de datos en azure y funciona correctamente, pero ahora, al intentar conectarme directamente desde el vb.net salta el error o errores.

    Os pongo la imagen del error. 

    La cadena de conexión que estoy utilizando es la siguiente:

    <!--'///////////////// CONEXIONES BASE DE DATOS. ////////////////////--> <connectionStrings> <clear /> <add name="PerseoSQLce" connectionString="Data Source= |DataDirectory|\PerseoSQLce.sdf;" providerName="System.Data.SqlServerCe.4.0" /> <!--Conexión en local/>!--> <!--Conexion a Sql Server (normal)/>!--> <!--add name="PerseoSqlEx" connectionString="Data Source=.\SQLEXPRESS;Initial Catalog=PerseoSqlEx;Integrated Security=TRUE" providerName="System.Data.SqlClient/>!-->

    <!--Conexión en remoto a Azure/>!--> <add name="PerseoSqlEx" connectionString="Server=tcp:financialsystem.database.windows.net,1433;Initial Catalog=PerseoSqlEx;Persist Security Info=False;User ID=xxxxxxx;Password=xxxxxxxxx;MultipleActiveResultSets=False;Encrypt=True;TrustServerCertificate=False;Connection Timeout=30;" />

    <!--<add name="PerseoSqlEx" connectionString="Data Source=192.168.56.1\SQLEXPRESS;Initial Catalog=PerseoSqlEx ;Persist Security Info=true" providerName="System.Data.SqlClient "/>!--> <!--Conexion MySQL/>!--> <add name="PerseoMySql" connectionString="Server=127.0.0.1;Port=3306;Database=PerseoMySql;User Id=xxxxxxx;Password=xxxxxxxx;" providerName="MySql.Data.MySqlClient" /> Es la marcada en negrita.

    No se donde está el error por lo que os agradeceré si podéis me indiquéis que hago mal.

    Un cordial saludo a todos.

    Gemma


    • Cambiado EricRR miércoles, 21 de abril de 2021 19:52 DBA
    miércoles, 21 de abril de 2021 15:57

Respuestas