none
Unit Tests con web service RRS feed

  • Pregunta

  • Hola

    Estoy desarrollando un proyecto de pruebas para probar una solución que tengo.

    La solución tiene varios proyectos que interactúan.

    Uno de ellos es un proyecto de Web Service en WCF.

    Yo quiero probar las funciones de una clase de otro proyecto donde se llama al proyecto anterior.

    Pero al iniciar las pruebas no levanta el WS en test o debug por lo que el error que muestra es: System.ServiceModel.EndpointNotFoundException: No había ningún extremo escuchando en http://localhost:8030/BancaPrivada_PlazoFijoSvc.svc

    La pregunta: ¿Se puede iniciar en debug en el ClassInitialize? ¿Como? ¿Como se escribe en código para levantar el debugger?

    jueves, 16 de mayo de 2019 16:12

Todas las respuestas

  • Hola  MrGuille

     

    Gracias por levantar tu consulta en los foros de MSDN. Con respecto a la misma, te recomiendo ingresar al siguiente enlace donde se expone una pequeña guía que te puede ser de utilidad para resolver el problema que presentas.

    https://docs.microsoft.com/ga-ie/visualstudio/test/unit-test-your-code?view=vs-2017

     

    Gracias por usar los foros de MSDN.

     

    Pablo Rubio

     ____

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde.

     

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft. 

     

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    viernes, 17 de mayo de 2019 18:15
    Moderador