none
Problema con Imagen en formulario RRS feed

  • Pregunta

  • Hola, estoy probando poner una imagen de fondo en mi splash screen y me aparece todo negro. Intente cambiando el formato de la imagen pero pasa lo mismo. que podrá ser??

    gracias

    lunes, 26 de abril de 2010 9:32

Respuestas

  • hola

    has probado con un control Image, para verificar si se visualiza

    o editar la imagen con el Paint para validar que este e un formato correcto, prueba pasarla a bmp, solo para descartar el formato

    crea una aplicacion de pruebam en dodne solo agregues el control PictureBox, y en timepo de diseño agrega la imagen, tambine prueba cargarla en tiempo de ejecucion, mediante

    PictureBox1.Image = Image.FromFile("path");

    para ver si asi funciona

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    lunes, 26 de abril de 2010 19:16

Todas las respuestas

  • Umh es estraño lo que comentas que tipo de imagen estás poniendo?

    la estás poniendo en el MainLayoutPanel???


    Para el correcto funcionamiento, y que otros usuarios se puedan beneficiar de la solucion de esta pregunta por favor marca las respuestas que te hayan ayudado como "Respuesta".
    Si la respuesta te ha sido util Votala.
    Mi Blog: Jtorrecilla
    Enlace a Faq de Winforms en Ingles Muy bueno
    lunes, 26 de abril de 2010 9:35
    Moderador
  • Hola, como tienes puesto el SizeMode?

    prueba con StretchImage.

    Ya nos diras.


    Colabora con el foro: Si este mensaje te es de utilidad marcalo como respuesta.

    Quique Martínez

    Blog: http://www.qmartinez.es

    Grupo .Net: http://www.secondnug.com


    lunes, 26 de abril de 2010 12:07
  • He probado poner la foto en un picturebox y aparece el cuadro negro, y hasta probe ponerla en el background del form y tambien aparece negro. Y probe con fotos .jpg, png y sigue apareciendo negro el cuadro de la foto.

    muchas gracias.

    lunes, 26 de abril de 2010 18:36
  • hola

    has probado con un control Image, para verificar si se visualiza

    o editar la imagen con el Paint para validar que este e un formato correcto, prueba pasarla a bmp, solo para descartar el formato

    crea una aplicacion de pruebam en dodne solo agregues el control PictureBox, y en timepo de diseño agrega la imagen, tambine prueba cargarla en tiempo de ejecucion, mediante

    PictureBox1.Image = Image.FromFile("path");

    para ver si asi funciona

    saludos


    Leandro Tuttini

    Blog
    Buenos Aires
    Argentina
    lunes, 26 de abril de 2010 19:16
  • ¡Hola!

    ¿Las informaciones fueran utiles para solucionar su problema?

    ¡Gracias!
    Rafael Fagundes - Marque la respuesta como correcta si te ha sido de utilidad!
    lunes, 3 de mayo de 2010 13:12
    Moderador
  • como te fue con esto?
    Juan Carlos Ruiz
    Microsoft MVP - Visual C#
    Visita mi blog:

    Ideas de Un Conejo - http://juank.black-byte.com

    lunes, 3 de mayo de 2010 13:55
    Moderador
  • Tenía razón Leandro. El problema era el formato de la imagen, y ya me habia pasado antes pero con una imagen muy pesada en megabytes, pero ahora la imagen era de unos pocos kbytes y pequeña. Pero en fin, cambie el formato de .bmp a jpg y funciona bien. Muchas gracias a todos.
    martes, 4 de mayo de 2010 23:35