none
Problema con Reportes en Team Foundation RRS feed

  • Pregunta

  • Hola a Todos

    Colegas tengo un duda consulta, miren tengo un proyecto en team foundation 2010 y un team project de c# 2010 dentro del cual estamos creando algunos reportes de crystal reports, cada programador tiene su propio entorno de codigo descargado en su pc. Todo nitido hasta este momento

    El problema es que al momento que alguien desea abrir un RPT se tarda una enormidad en hacerlo, cosa que no deberia de suceder debido a que en teoria el source control tiene una copia local en cada pc y en este caso el programador esta abriendo un reporte que nadie mas esta trabajando. 

    Desconozco si existe alguna situacion anomala entre team foundation y los reportes de Crystal, es mas he intentado instalar el VS 2010 en mi server de team foundation para ver si la carga del reporte se hace mas rapida pero si bien es cierto mejoro siempre esta bastante lento y mas sobretodo para compilarlo. Cree un reporte solo con un dataset para probar si es que nuestros reportes son muy pesados y aun ese reporte con un dataset que solo muestra 3 campos se tarda enormidades en abrirse

    Tienen alguna idea o conocen de algo que suceda con TFS 2010 y los Reports de Crystal del VS 2010

    Les agradecere mucho sus comentarios

    Saludos


    Javier Montero

    lunes, 1 de julio de 2013 0:20

Respuestas

  • Hola Javier; es poco probable que el problema esté relacionado con TFS. Como tú mismo comentas, el RPT está copiado en local, por lo que la operación de abrirlo en principio no tiene ninguna interacción con TFS. Además, si el resto de operaciones con TFS (en concreto con el control de versiones) no son tan lentas, por ejemplo proteger o desproteger cualquier fichero, no hay razón para pensar que el origen del problema está ahí.

    Puedes descartar definitivamente esa opción si obtienes una copia local del proyecto y desde visual studio la desconectas del control de versiones. Si en ese caso sigue tardando en cargar, ya sabes seguro que no es por el TFS.

    Yo intentaría investigar qué hacen los RPT, si están validando la conexión a la base de datos al abrirse o hacen operaciones de ese tipo es posible que el problema esté ahí.

    Un saludo.

    lunes, 1 de julio de 2013 12:17

Todas las respuestas

  • Hola Javier; es poco probable que el problema esté relacionado con TFS. Como tú mismo comentas, el RPT está copiado en local, por lo que la operación de abrirlo en principio no tiene ninguna interacción con TFS. Además, si el resto de operaciones con TFS (en concreto con el control de versiones) no son tan lentas, por ejemplo proteger o desproteger cualquier fichero, no hay razón para pensar que el origen del problema está ahí.

    Puedes descartar definitivamente esa opción si obtienes una copia local del proyecto y desde visual studio la desconectas del control de versiones. Si en ese caso sigue tardando en cargar, ya sabes seguro que no es por el TFS.

    Yo intentaría investigar qué hacen los RPT, si están validando la conexión a la base de datos al abrirse o hacen operaciones de ese tipo es posible que el problema esté ahí.

    Un saludo.

    lunes, 1 de julio de 2013 12:17
  • Gracias por responder Jose Luis

    La verdad que yo tambien tengo esa sospecha ya que como tu mencionas ese codigo esta localmente en la maquina de cada programador y no veo el problema como algo de conectividad o algo por el estilo en el TFS.

    Sinceramente que hare una revision a fondo de que llevan esos reportes porque creo que estan satanizando a mi pobre server de TFS sin ser el culpable 

    Saludos y gracias de nuevo Jose Luis


    Javier Montero

    lunes, 1 de julio de 2013 14:37