none
Error al insertar formula en Excel desde c# RRS feed

  • Pregunta

  • Buenas tardes compañeros...

    Alguien me podria decir cual el es error que estoy cometiendo....

    Tengo  el siguie nte codigo para insertar una formula, pero esta marcado un error...

    hoja.Cells[40, 1].FormulaR1C1 = "=PROMEDIO((A10:A39))";

    Gracias por la ayuda


    Jose Maria Bracamontes Almeraz

    martes, 25 de noviembre de 2014 17:55

Respuestas

  • Excel también cuenta con las celdas vacías para calcular el promedio.

    Para calcular el promedio sin tomar los valores vacíos o cero puedes usar esta fórmula:

    = SUMA(A10:A39) / CONTAR(A10:A39) - CONTAR.SI(A10:A39; 0)


    Saludos, Javier J

    • Marcado como respuesta jmba24 jueves, 4 de diciembre de 2014 17:57
    viernes, 28 de noviembre de 2014 7:55

Todas las respuestas

  • Ese error te lo da porque hay celdas sin ningún valor.

    Si colocas el cursor sobre el icono de la exclamación te indicará la causa del error.


    Saludos, Javier J

    miércoles, 26 de noviembre de 2014 11:01
  • No creo que ese sea el error ya que el promedio es la celda a10 a la a39 y en la celda a16 existe el valor 2, por lo que deberia dar el promesio de ese unico valor....

    saludos


    Jose Maria Bracamontes Almeraz

    jueves, 27 de noviembre de 2014 16:22
  • Excel también cuenta con las celdas vacías para calcular el promedio.

    Para calcular el promedio sin tomar los valores vacíos o cero puedes usar esta fórmula:

    = SUMA(A10:A39) / CONTAR(A10:A39) - CONTAR.SI(A10:A39; 0)


    Saludos, Javier J

    • Marcado como respuesta jmba24 jueves, 4 de diciembre de 2014 17:57
    viernes, 28 de noviembre de 2014 7:55