none
Problema con crystal reports e imagenes RRS feed

  • Pregunta

  • Buenos días.

    Me encuentro desarrollando una aplicación web y me he topado con un problema. Resulta que he desarrollado una pantalla para la impresión de etiquetas de producto. 

    El problema lo tengo con el tamaño de las imágenes. Antes usábamos una base de datos Access y en el diseñado de informes, se agregaba un campo imagen y en sus propiedades se establecía El modo de cambiar de tamaño a Zoom, con lo que las imágenes se "adaptaban" al objeto.

    Al cambiar el sistema de impresión, uso Crystal Reports y lanzo la impresión directamente a una impresora térmica. El problema que tengo es que la opción que tenia con Access no la tengo y por lo tanto en algunas fotos (las cuales tienen diferente tamaño) se deforman y no salen con buena calidad.

    ¿Hay alguna forma de realizar este "zoom" en cristal reports desde el diseñador o por código?

    Las imágenes las paso de forma dinámica.

    Gracias de antemano.

    Un saludo.

    miércoles, 22 de mayo de 2019 16:04

Todas las respuestas

  • Buenos días.

    Me encuentro desarrollando una aplicación web y me he topado con un problema. Resulta que he desarrollado una pantalla para la impresión de etiquetas de producto. 

    El problema lo tengo con el tamaño de las imágenes. Antes usábamos una base de datos Access y en el diseñado de informes, se agregaba un campo imagen y en sus propiedades se establecía El modo de cambiar de tamaño a Zoom, con lo que las imágenes se "adaptaban" al objeto.

    Al cambiar el sistema de impresión, uso Crystal Reports y lanzo la impresión directamente a una impresora térmica. El problema que tengo es que la opción que tenia con Access no la tengo y por lo tanto en algunas fotos (las cuales tienen diferente tamaño) se deforman y no salen con buena calidad.

    ¿Hay alguna forma de realizar este "zoom" en cristal reports desde el diseñador o por código?

    Las imágenes las paso de forma dinámica.

    Gracias de antemano.

    Un saludo.

    Se me olvidó comentar que al report le paso la imagen como campo byte[] en vez de pasarla la ruta de la imagen.

    Esto lo hago así por que no se por que, cuando le paso la ruta de la imagen al imprimir no aparece la imagen, sin embargo si lo hago depurando la aplicación antes de publicar si que me aparece.... 

    La ruta que le paso es algo asi como, "G:\foto\nombre.jpg" y la unidad G es una unidad de red....

    Saludos.

    jueves, 23 de mayo de 2019 10:09