none
Campo tipo booleano de las búsquedas personalizadas (avanzadas) de Sharepoint 2010, no obtiene resultado RRS feed

  • Pregunta

  • Buenas,

    Quisiera saber como hacer cuando, genero un WP en el que incluyo un cuadro de búsqueda avanzada en Sharepoint 2010, y los campos tipo "booleanos" no me generan resultados. He probado cambiando el tipo de campo en el HTML del WP y nada...

    PD: Es como si no existieran registros que incluyan esos valores..

    Agradecería sus respuestas!!!

    miércoles, 25 de septiembre de 2013 14:59

Todas las respuestas

  • Hola Rubi,

    En el tema de búsqueda avanzada te refieres a que estas utilizando el motor de búsqueda de sharepoint o bien te has realizado un desarrollo personalizado y estas realizando consultas CAML contra una determinada lista?

    Para el caso de que estes utilizando fast, lo que te recomiendo es que si quieres que búsque por un determinado campo añades este campo a las propiedades a buscar cuando realizas un rastreo de esta forma el búscador podrá generar resultados.

    En el caso de que lo que estes haciendo es un desarrollo a medida en las consultas CAML con booleanos tienes que poner como valor 0 o 1 no true o false. Te recomiendo que te descargues un generado de consultas CAML como 2uCamlQuery y de esta forma obtengas la consulta correcta.

    Cualquier aspecto ya comentas,

    Un saludo,


    MCPD SharePoint 2010 Mi blog: http://blogs.encamina.com/desarrollandosobresharepoint Twitter: @AdrianDiaz81

    viernes, 27 de septiembre de 2013 5:22